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Chapter 1

Installation

This chapter describes the di�erent steps to follow in order to have a fully functionnal installation of the
BioXpress software.

The installation procedure is straightforward. It is summarized below.

1. Downloading

2. Installing

3. Registering

4. Requesting licenses

The two �rst points are described below in x1.2 and x1.3, whereas the two last points are detailed in the
section about the Licenses Wizardin x2.1.1. Before starting the installation, you may want to check the
System Requirementslisted in the next paragraph.

1.1 What are the system requirements

Your system must meet the following requirements in order toexecute the software.

Requirements for Windows R
 based system
Hardware Minimum of 256 Mb of RAM, 1 Gb recommended.

Video Card : VGA.
AMD or Intel x86 processor at 1.0 Ghz or higher.

Software Windows c
 XP or Windows R
 Vista.
Sun JavaTM 1.5 or higher.
20 Mb of available disk space.

Requirements for Mac OS X based system
Hardware Minimum of 256 Mb of RAM, 1 Gb recommended.

Video Card : VGA.
AMD or Intel x86 processor at 1.0 Ghz or higher.

Software Requires Mac OS X v. 10.4 or higher.
Apple JavaTM 1.5 or higher.
20 Mb of available disk space.

Requirements for Linux based system
Hardware Minimum of 256 Mb of RAM, 1 Gb recommended.

Video Card : VGA.
AMD or Intel x86 processor at 1.0 Ghz or higher.

Software Kernel 2.4 or higher.
Sun JavaTM 1.5 or higher.
20 Mb of available disk space.

BioXpress User Guide Version 1.1 1



2 CHAPTER 1. INSTALLATION

1.2 How to obtain a copy of the software

The BioXpress software can be either downloaded from our website atwww.bioxpr.com/software or a
copy can be requested by contacting BioXpr o�ces (sales@bioxpr.com).

BioXpr | Sales department
rue du S�eminaire, 22
5000 Namur
Belgium

1.3 How to install the software

You start the installation by double clicking on the icon of t he installer program. If you downloaded the
software the icon can be found in the download folder, generally the desktop.

On Windows R
 based systems : The installer program is called BioXpress setup.exe.

Windows R
 based systems : Double click on the icon
to start the installation.

On Mac OS X : After unpacking the install.tar �le the installer program can be launched by
double clicking on its icon.

Mac OS X: First unpack the install.tar �le, then dou-
ble click on the Install icon to start the installation.

On Linux : The installer program is called install.jar . Depending on the con�guration of the
system the installer can be launched either by double clicking on the icon or by opening a terminal
and executing the following command: java -jar install.jar

Linux: Either double click on the icon to start the
installation or open a terminal to execute the \java
-jar install.jar" command.

NOTE : Although the installation procedure is very similar on the di�erent operating system the
default values for the options can vary.

1. Welcome screen
On the welcome screen the software is brie
y presented.

BioXpress User Guide Version 1.1



1.3. HOW TO INSTALL THE SOFTWARE 3

Click on Next to continue.

2. License agreement
A copy of the terms of the License agreement is available at the end of this document.

3. Speci�cation of the installation folder
A default directory is given depending on your access rights on the computer.
If you do not have the system wide access, the default option is similar to
the following \ C:nnDocuments and Settingsn[user name]nBioXpr nBioXpress"
on Windows, or \ Users/[user name]/BioXpr/BioXpress " on Mac OS X, or
\ /home/[user name]/BioXpr/BioXpress " on Linux.

Click on Next to continue.

If needed, the installation program will create the installation directory. If the directory cannot be
created a message box with an explanation message will pop up. Most of the time, it is because
you do not have the access rights to create the given directory. You will then be prompted to select
another installation directory. Please contact your system administrator.

4. Selection of the packages for installation
The available packages are the core with the main application, the plugins which perform speci�c
tasks, the tools which are shared by the plugins, and �nally the documentation. Everything is
selected by default. Refer to the Sections about the application and the plugins for additional
information.

Select the packages for installa-
tion and click on the Next but-
ton to continue.

BioXpress User Guide Version 1.1



4 CHAPTER 1. INSTALLATION

5. Setup Menu and Desktop shortcuts
By default, the software menu shortcuts will be installed in \BioXpress" and an additional shortcut
will be created on the desktop.NOTE : On Mac OS X, the installer is not able to create shortcuts.

Click on Next to continue.

6. Con�rmation of the options for the installation

Click on Install to start the in-
stallation.

7. Installation in progress

Wait until the installation is
complete.

8. Installation check
The installation program checks the di�erent components ofthe applications and their dependencies.

BioXpress User Guide Version 1.1



1.3. HOW TO INSTALL THE SOFTWARE 5

Wait until the check is com-
plete.

9. Installation is complete
The installation is now complete and the program is ready foruse.

Click on Done to quit the in-
staller.

NOTE : On Windows Vista, the installation might end with the follow ing message \This program
might not have installed correctly". This warning message can be ignored and you can safely click
on \ This program installed correctly".

Click on This program installed
correctly .

An uninstaller program has also been created. It can be activated either via the menu or via the
Uninstaller directory of the BioXpress installation path.

The new icon and entries in the
Programs menu.

BioXpress User Guide Version 1.1



6 CHAPTER 1. INSTALLATION

1.4 How to uninstall the software

To uninstall the software, select the \Uninstall BioXpress" entry of the Programs menu.

NOTE : The uninstaller can also be run from the command line :java -jar uninstaller.jar

1. Con�rm your choice
The option \ Force the deletion of ..." will remove the BioXpress installation directory even if the
directory is not empty.

Click on the Uninstall button to
start the uninstallation process.

2. The uninstallation procedure is complete

Click on the Quit button.

BioXpress User Guide Version 1.1



Chapter 2

BioXpress { The software

The BioXpress software is designed around plugins and tools. The plugins can be viewed as standalone
applications performing speci�c tasks such as the design ofPCR primers or probes. The tools provide
common functionalities for the di�erent plugins, i.e. the i mport of a sequence from the Internet or the
submission of a BLAST.

The plugins have their own window and menu inside the BioXpress window. In order to distinguish
between the main application's menu and the plugin's menu the following convention is used throughout
the User Guide :

The About item of the Help menu of the BioXpress main window is noted as,

[BioXpress menu]Help > About

Whereas theCloseitem of File menu of a plugin is referenced as,

[plugin menu]File > Close

Valid licenses are required for the di�erents plugins and tools. The installation of new licenses is
explained in the next point.

2.1 Licenses

Three types of licenses are available.Evaluation licenses are usually valid for one month with no re-
striction on the number of users or installed computers. In addition to Evaluationlicenses,Educational
and Commerciallicenses can be purchased on our website (www.bioxpr.com/software). The terms and
conditions of these licenses can be consulted on our website(www.bioxpr.com).

The easiest way to register and install your licenses is to use the License Wizard(x2.1.1). However,
it is possible to manually install licenses with the License Manager(x2.1.2) and register your computer
(x2.1.3).

2.1.1 License Wizard

The License Wizardis launched when the program is run for the �rst time. Later you can execute again
the License Wizardfrom the Help menu.

[BioXpress menu]Help > Licenses wizard

In four steps the License Wizardguides you through the registration procedure and the installation of
your licenses. TheLicense Wizardcan also request evaluation licenses for the installed plugins and tools.

BioXpress User Guide Version 1.1 7



8 CHAPTER 2. BIOXPRESS { THE SOFTWARE

1. In the �rst step, the wizard connects to our web site with th e provided login, i.e. your email,
and password. If you are not yet registered, please press theRegisterbutton. At the end of the
registration process, an email will be sent to your email address. Please click on the provided link
to con�rm your account. This is required in order to proceed further.

The License Wizard : user iden-
ti�cation step. Click on Next to
proceed.

2. In the second step, the wizard lists the network adapters that can be used to identify and register
your computer. The �rst one is selected by default. The wizard will notify you if your system is
already registered on our website.

IMPORTANT NOTE : if the network adapter used to identify your computer is changed, your
licenses might be invalidated. In such case, you may want to contact us (support@bioxpr.com) in
order to generate new licenses for your computer.

The License Wizard : Com-
puter identi�cation step. Click
on Next to proceed.

Please note that the stored information can be deleted by accessing youraccount on our web
site (www.bioxpr.com/software/systems.php).

3. Once your computer is identi�ed, the wizard lists the available licenses. Evaluation licenses can
also be requested at this stage. You can select/unselect thelicense(s) you want to download and
install by clicking the corresponding button.

The License Wizard : license
selection step. Click on Next
to proceed.
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2.1. LICENSES 9

4. In the next screen, a summary of the actions to be performedis shown. You have the possibility
to go back and change the selection of licenses. By pressing the Next button the selection is
con�rmed and the wizard performs the required actions such as requesting an evaluation license
and/or downloading and activating the selected licenses.

The License Wizard : li-
cense selection con�rmation
step. Click on Next to con�rm
your choice and proceed.

The �nal screen lists the plugins and tools that are now available for further use.

The BioXpress license wizard :
Final step. Click on Done to
close the wizard and start using
BioXpress.

At this point you are able to use the BioXpresssoftware.

2.1.2 License Manager

[BioXpress menu]Help > Manage licenses

The License Managerenables the download or importation of licenses, the removal of expired licenses,
and the activation of new licenses. In the dialog box, you �nd the list of installed licenses and the related
information : if the license is in use or not, for which component (plugin or tool), its expiration date and
its type ( Evaluation, Commercial or Educational).

The BioXpress license manager.
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10 CHAPTER 2. BIOXPRESS { THE SOFTWARE

Import a license from the web server
Provided you are registered, it is possible to download the licenses attached to your account. For
this, you need your login and password. If you are not registered yet, press theRegisterbutton and
an Internet navigator will open the BioXpress registration webpage.

Enter your login and password
to connect to the BioXpress
server.

The Get licensesbutton will retrieve the available licenses for the current user account on the
computer. An error message will be shown in case of failure. In most cases, this is due to a network
error ; you will be given the possibility to retry.

Import a license from a �le
This method should be used if the import from our web site cannot be used because the computer
has no connection to the Internet or it is behind a �rewall. Yo ur licenses can be downloaded or
sent to your email address from our server (www.bioxpr.com/software/licenses.php). In the dialog
box simply select the license �les and press theOpenbutton.

Remove a license
Click on the Remove selectedbutton to delete a license from the computer.

Active a license
In case you have several licenses for the same component, youmay select which one is to be activated.
To mark a license as to be activated, press theUse selectedbutton.

When a license is no longer valid, theLicense Managerdeactivates it automatically. You must then
install a new license in order to continue to use the component.

2.1.3 Register your computer

[BioXpress menu]Help > Register computer

In order to request Commercialor Educational licenses, you must �rst identify the computers on which
the software will be executed. You can do so by selecting theRegister computermenu item and follow the
instructions. The collected information will only be used for licensing purposes. Those information can
be viewed or deleted from our server through your account (www.bioxpr.com/software/systems.php).

1. Retrieve system information.
The program collects the following information about your computer : the hostname, the ip, the
Mac-Address and the user login.

2. Select a device.
You have to select a device from the list of network adapters available on your computer. The
license veri�cation procedure will later use this information to identify your computer.

3. Login and password to connect to the BioXpr website.
You need to be registered in order to connect to our server. Toregister, please click on theRegister
button. This will open the registration web page.
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2.1. LICENSES 11

Enter your login and password
to connect to the BioXpr server.

4. Sending the information to the server.
The program sends the collected information to the server. If an error occurs or if your computer
is already registered, a message is shown.

5. Con�rmation of registration from the server.
Your computer is now identi�ed.

BioXpress User Guide Version 1.1



12 CHAPTER 2. BIOXPRESS { THE SOFTWARE

2.2 A quick tour of BioXpress

The main window of the program consists of the application menu bar and the workspace for the
tasks/plugins. A new prediction is started by selecting a plugin in the New prediction... entry of the
File menu. For example,

[BioXpress menu]File > New ... > qPCR > TaqMan probes

You can open previous tasks with theOpen prediction ...entry of the File menu.

[BioXpress menu]File > Open prediction

The Close command ends the current prediction/plugin whereas the Close all item terminates all
tasks/plugins. You will be asked to save your data.

You can switch between tasks with theWindow menu. The Tools menu lists the available tools for the
active task/plugin. The Help menu gathers the copyright information of the software and as explained
in the previous point the License Wizardand managers for the licenses and the identi�cation of your
computer.

Application menu bar, i.e. "BioXpress menu"

Workspace

Secondary menu bar, i.e. "Plugin menu"

The BioXpress application with the File menu shown.
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Chapter 3

The \PCR primers" plugin

3.1 Introduction

The PCR or Polymerase Chain Reaction is an in-vitro technique widely used in molecular biology to
selectively amplify a piece or a speci�c stretch of DNA. The target region to amplify is de�ned by two
primers and is called the amplicon. The selectivity of the primers is important to ensure that only the
intended region of the DNA template or sample is ampli�ed.

Schematic representation of the forward and reverse primer s and the amplicon.

The experimental PCR methodology consists of 20 to 40 cyclesduring which the temperature of the
sample is changed to discrete and selected values corresponding to di�erent biological processes or steps.
There are three steps in typical cycle:

1. Denaturation step.

This is the �rst step in the cycle. The sample is heated to the melting temperature of DNA, usually
around 94-96� C for 20-30 seconds. The DNA template separate into two single strands.

2. Annealing step.

During this step, in which the reaction temperature is lowered to 50-65 � C for 20-40 seconds, the
primers and the single-stranded DNA sample bind together.

3. Extension/elongation step.

In this step, the temperature is elevated to the optimal temperature of the DNA polymerase used in
the experimental procedure. The polymerase synthesizes new strands complementary to the DNA
sample starting from the 3' end of the primers and going in the5' to 3' direction. The duration of
this step depends on both the used DNA polymerase and on the length of the region to be ampli�ed.

Additional initial and �nal steps can be added before and after the cycles depending on the exact
experimental procedure.

3.2 The plugin interface

The PCR interface consists of three tabs. One enters the DNA sequence of the sample in the �rst tab
(the DNA sequence of the sample is referred as the reference sequence in the rest of the User's Guide).
One speci�es the parameters for the prediction in the secondtab. Once the prediction is completed, a
third tab displays the results.

BioXpress User Guide Version 1.1 13



14 CHAPTER 3. THE \PCR PRIMERS" PLUGIN

3.2.1 The \Sequence" tab

In this tab, one enters the reference DNA sequence either by typing or pasting it, or importing it from a
�le with the Open item of the File menu of the plugin, or using the Search sequencesitem of the Tools
menu of the plugin to import a sequence from the Internet, currently from the NCBI server. This tool is
explained in the sectionSequence Search, on page69.

The Sequence tab of the PCR plugin interface.

The format of the imported reference sequence can be one of the following:

FASTA . This is a simple text-based format in which a sequence de�nition is preceded by a title or
comment line starting with the greater-than symbol (' > ').

GenBank is a text-based format containing annotations for the database produced by the National
Center for Biotechnology Information (NCBI).

EMBL is the text-based format developed by the European Molecular Biology Laboratory.

Text . Only valid symbols from the �le are kept, i.e. A, C, G, T, and t he ambiguous characters as
de�ned by IUPAC.

Likewise the Text format, the other formats support ambiguous symbols.

By default, the prediction is performed on the whole sequence. However, it is possible to de�ne or
exclude a range or a set of ranges by checking theLimit the prediction on speci�c sequence regionoption
at the bottom of the sequence tab, additional options will then appear as shown on the next Figure.

It is possible to limit the prediction on speci�c regions of t he sequence or to exclude
speci�c regions of the sequence from the prediction.

These additional options are:

Using base range. A range or a set of ranges separated by semi-colon can be speci�ed.

Using sequence annotation(s). The set of ranges are de�ned by a speci�c annotation.

Exclude from the prediction. The set of ranges de�ned on the left is excluded from the predic-
tion.
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3.2. THE PLUGIN INTERFACE 15

NOTE : The predicted amplicons will be totally included in a region or in other words the predicted
amplicons will not overlap adjacent regions.

NOTE : The Range group of the Parameterstab can also be used to �ne-tune the location of the
primers.

3.2.2 The \Parameters" tab

This tab speci�es all the parameters for the prediction. The parameters are gathered in four groups :
General, Advanced, Filters and Range. Seex3.4 for a detailed description of the parameters.

Under the Generalgroup are listed parameters such as the oligonucleotide concentration as well as
the salt concentrations in the sample but also the required features of the primers and the amplicon.

The parameters in the Advancedgroup are used to select on the one hand the theoretical meth-
ods to estimate the � G of formation of homoduplex and heteroduplex as well as the methods to
compute the melting temperature (Tm ) for the primers and the amplicon; and on the other hand
the requirements about the selectivity of the primers (alsoknown as the unicity1 of the solutions
for the primers) and the criteria to discard primers and pairs of primers based on the presence of
a secondary structure.

The activation and deactivation of �lters is done in the Filters group. For example, if the �lter
Length limits for the primers is activated, the software will discard potential primers based on the
length limits given by the Min length and Max lengthprimer parameters of the Generalgroup. On
the contrary, if the �lter is unchecked, those parameters are deactivated and the software will not
use them to discard potential primers during the prediction.

In the Rangegroup, it is possible to specify explicitly where the forward and reverse primers will
be generated. It is important that the range herein entered must be compatible with the regions
speci�ed in the Sequencetab. It is possible to �x the range for either of the primers or for both of
them.

The Parameters tab of the PCR plugin interface (General).

1The unicity tests ensure that the solutions are unique on the reference sequence.
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16 CHAPTER 3. THE \PCR PRIMERS" PLUGIN

The Parameters tab of the PCR plugin interface (Advanced).

The Parameters tab of the PCR plugin interface (Filters).

The Parameters tab of the PCR plugin interface (Range).
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3.2. THE PLUGIN INTERFACE 17

It is possible to import and export the set of parameters for subsequent use with the Import and
Export buttons. In addition, one can set the current parameter selection as the default one for the next
PCR task with the Set as defaultbutton. Finally, one can reset the values to the BioXpr default values by
clicking the Reset to BioXpr defaultbutton. The prediction starts by clicking the Start predictionbutton
or the button in the tool bar ( ). A window opens and shows the state of completion of the prediction.

The Prediction is complete. One can view
the statistics for each �lter by clicking on
the corresponding button.

Once the prediction is complete, the results are displayed in the Resultstab. The statistics for each
�lter, i.e. the number of sequences passing through the �lters, are available by clicking theView statistics
button. They are also available via the item Statistics of the View menu.

The statistics are of particular interest especially when the prediction does not deliver any results.
You can easily �gure out the parameters responsible for discarding too many solutions and modify their
values accordingly.

The statistics for the prediction.

3.2.3 The \Results" tab

This tab is divided into two parts. The lower table lists all t he results of the prediction whereas in the
upper part selected solutions are graphically visualized.The color of a solution is rating dependent :
from bright green (highest rating) to bright red (lowest rat ing). Please note that the rating is not a
measure of the likelihood of success of the experiment with the corresponding solution but a measure of
the relevance of the solution to the parameters entered for the prediction. Each solution consists of a
forward primer (FP), a reverse primer (RP) hence the resulting amplicon.
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18 CHAPTER 3. THE \PCR PRIMERS" PLUGIN

Toolbar

Graphical visualization of the selected solutions

Table with the solutions of the prediction

The Results tab of the PCR plugin interface.

The columns in the table can be (a) resized by moving the mouseon the right edge of title, (b)
rearranged by dragging and, (c) hidden or shown via the button ( ) available in the right top corner of
the table. The button shows a drop down menu with the headers of the columns of the table. A brief
description is given below.

Columns of the table for the solutions of a
prediction

Checked Mark the solution.
ID ID of the solution.
Rating Total rating of the solution.
FP/RP Rat-
ing

Rating of the Forward/Reverse Primer.

FP/RP Start 5' position of the Forward/Reverse
Primer.

FP/RP
length

Length of the Forward/Reverse Primer.

FP/RP T m Melting temperature of the For-
ward/Reverse Primer.

FP/RP
%GC

% GC of the Forward/Reverse Primer.

FP/RP Forward/Reverse Primer sequence.
Amplicon
length

The length of the amplicon.

T a Temperature of annealing.
Horizontal
Scroll

Enable/disable the horizontal scrolling of
the table.

Pack All
Columns

Resize the width of the columns to �t
best their contents.

Pack Se-
lected Col-
umn

Resize the width of the selected column.
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3.2.4 Menu and tool bar

The commands in theFile menu are described below.

Command in the
File menu

Description

Open sequence Open a sequence �le in the current
window or a previously saved pre-
diction in an new window.

Save Save the prediction.
Save as Save the prediction under another

�le name.
Export as Export the solutions of the predic-

tion in a text �le, CSV �le, or Excel
�le.

Create a report Generate a report with the selected
solutions. The report is viewed in
a separate window and can be ex-
ported as a PDF �le or directly
printed. It is possible to customize
the content and the presentation,
export and import the resulting
con�guration, make it as the de-
fault or even reset to the initial con-
�guration.

Close Close the current window.

The Edit menu depends on the active tab. It gathers the commands for copying the selected solutions,
search for sub-sequences or navigate throughout the reference sequence, ... The description of each of the
commands is given in the following table.

Command in the
Edit menu.

Description

Cut In the Sequence tab, cut the selec-
tion into the clipboard.

Copy In the Sequence tab, copy the selec-
tion into the clipboard. In the Re-
sult tab, copy the content of the se-
lected solutions into the clipboard.

Paste In the Sequence tab, replace the se-
lection by the content of the clip-
board.

Preferences... Change the preferences for display-
ing the di�erent elements.

Search on sequence... Search in the reference sequence a
sub-sequence or an annotation, ...
It is important to note that the re-
sults of the search process are cu-
mulative, i.e. they can be used to
highlight di�erent parts of the se-
quences.

Clean search Reset the search results.
Go to base Move the view to the given base.
Go to start Move the view to the 5' end of the

sequence.
Go to end Move the view to the 3' end of the

sequence.

The Tools menu lists the available tools on the software.
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Command in the
Tools menu.

Description

Property calculator For a selected solution it is possi-
ble to compute properties such as
the GC content, the melting tem-
perature, ... You have access to the
Property Calculator via the Tools
menu of the plugin or by right click-
ing either on a primer in the upper
graphical representation visualiza-
tion or on a solution in the lower ta-
ble. This tool is explained in section
Property Calculator, on page 67.

Sequence Search This tool allows the search of a spe-
ci�c sequence in several databases
of the NCBI web site by entering
criteria and download it in the Se-
quence tab. This tool is explained
in section Search sequence, on page
69.

The Selectionmenu is only active within the Results tab. The description of each of the commands
is given in the following table.

Command in the
Selection menu.

Description

Select all solutions Select all solutions.
Unselect all solutions Clear the selection.
Select checked Select all the solutions marked to

be kept.
Invert selection Inverse the selection.
Check all selected The selected solutions will be

marked to be kept.
Uncheck all selected The 'keep' status of the selected so-

lutions will be turned o�.
Invert check state For the selected solutions, inverse

the keep status.

The type of visualization and the amount of information shown can be tuned with the following
options, both available from the View menu or from the tool bar.
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Command in the
View menu.

Description

Show statistics Open a dialog box with the statis-
tics of the prediction.

Bases display Switch between two views of the ref-
erence sequence : in the �rst one,
each base is represented by its sym-
bol whereas in the second one, the
whole sequence is viewed as a line.

Multiline display For a long sequence, split the repre-
sentation of the sequence in several
lines on top of each others.

Properties Show the properties of the selected
solutions.

Heteroduplexes Show the potential heteroduplexes
between the primers of the selected
solutions.

Zoom in Zoom in the view
Zoom out Zoom out the view
Center view Move the view to the center of the

sequence.
Increase base size Increase the size of a base.
Decrease base size Decrease the size of a base.
Switch on the view of
both the tags and the
masks.
Sequence annota-
tion/Show tags

Switch on and o� the display of the
tags.

Sequence annota-
tion/Show masks

Switch on and o� the display of the
masks.

Sequence annota-
tion/Hide annota-
tions

Switch o� the display of both the
tags and the masks.

Export view as... Export the current view as an im-
age �le.
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3.3 Properties and Heteroduplexes of a solution

[plugin menu]View > Properties & View > Heteroduplexes

During the prediction, properties and structures for the primers and the amplicons or pairs of primers are
computed. To view the properties or the heteroduplexes of a primer or an amplicon, you may right click
either in table or in the graphical visualization. You can navigate through the selected solutions with
the navigation buttons. You can also print the properties of the current solution with the Print button.
Properties and structures are also available via the reports.

Navigation buttons

The properties of a solution. Use the navigation buttons to i terate through the selected
solutions.

Navigation buttons

The heteroduplexes of a solution. Use the navigation button s to iterate through the
selected solutions.
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3.4 Description of the parameters

Oligo concentration : concentration of oligonucleotide in the solution, in nM (10� 9M).
[General/Reaction conditions]

Salt concentration (Na+ ) : concentration of monovalent salt in the solution, in mM (10� 3M).
[General/Reaction conditions]

Salt concentration (Mg2+ ) : concentration of divalent salt in the solution, in mM (10 � 3M).
[General/Reaction conditions]

Min length : minimal length, in bp, for the primers or the amplicons.
[General/Primer ; General/Amplicon]

Max length : maximal length, in bp, for the primers or the amplicons.
[General/Primer ; General/Amplicon]

Min T m : minimal melting temperature, in � C, for the primers or the amplicons.
[General/Primer ; General/Amplicon]

Max Tm : maximal melting temperature, in � C, for the primers or the amplicons.
[General/Primer ; General/Amplicon]

Min GC : minimal content in G/C bases, in percentage, for the primers.
[General/Primer]

Max GC : maximal content in G/C bases, in percentage, for the primers.
[General/Primer]

Min num of GC on 3' end : minimal occurrence of G/C bases in the 5 last bases for the primers.
[General/Primer]

Max num of GC on 3' end : maximal occurrence of G/C bases in the 5 last bases for the primers.
[General/Primer]

Max num of repeated G or C : maximal occurrence of repeated G or C for the primers.
[General/Primer]

Max num of repeated A or T : maximal occurrence of repeated A or T for the primers.
[General/Primer]

Max num of repeated dinucleotides: maximal occurrence of repeated dinucleotides for the primers.
[General/Primer]

G or C at 3' end : if selected, the last residue for the primers must be a G or a C.
[General/Primer]

Max ambiguous bases: Maximal occurrence of ambiguous bases for the amplicon, excepted the
primers.
[General/Amplicon]

Max Tm di�erence between the primers : Maximal di�erence between the Tm for the primers
de�ning the amplicon, in � C.
[General/Amplicon]

Min T a : Minimal annealing temperature, in � C.
[General/Amplicon]

Max Ta : Maximal annealing temperature, in � C.
[General/Amplicon]

� G method : list of available theoretical methods to evaluate the �G.
[Advanced/Method]
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Tm method for primers/amplicons : list of available theoretical methods to evaluate the Tm for the
primers and amplicons.
[Advanced/Method]

Max consecutive matches: Maximal number of consecutive matches between a primer andthe DNA
sequence before considering a binding.
[Advanced/Primer unicity]

Max 3' consecutive matches: Maximal number of consecutive matches between the 3' end ofa
primer and the DNA sequence before considering a binding.
[Advanced/Primer unicity]

Max percent of matches: Maximal percentage of matches between a primer and the DNA sequence
before considering a binding.
[Advanced/Primer unicity]

Check using the Amplify method: Check the binding of a primer with the DNA sequence with the
Amplify method.
[Advanced/Primer unicity]

Min � G Hairpin : Discard primers forming a hairpin with an energy below the given �G in
kCal/mol.
[Advanced/Primer secondary structure]

Min � G Hairpin in 3' : Discard primers forming a 3' hairpin with an energy below the given �G
in kCal/mol.
[Advanced/Primer secondary structure]

Min � G homoduplex: Discard primers forming a homoduplex with an energy below the given �G
in kCal/mol.
[Advanced/Primer secondary structure]

Min � G 3' homoduplex : Discard primers forming a 3' homoduplex with an energy below the given
�G in kCal/mol.
[Advanced/Primer secondary structure]

Max number of hydrogen bonds: Discard primers forming homoduplex or heteroduplex having a
number of hydrogen bonds above the given limit.
[Advanced/Primer secondary structure ; Advanced/Pair of primers secondary structure]

Min � G heteroduplex: Discard primers forming heteroduplex with an energy belowthe given �G
in kCal/mol.
[Advanced/Pair of primers secondary structure]

Min � G heteroduplex in 3' : Discard primers forming a cross-dimer in 3' with an energy below the
given �G in kCal/mol.
[Advanced/Pair of primers secondary structure]
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Chapter 4

The \TaqMan probes" plugin

4.1 Introduction

The TaqMan procedure is a re�nement of the PCR technique as itenables to measure in real time the
number of copies of the DNA template present in the PCR. In the classical PCR methodology is not
possible to measure the evolution of the reaction within thesample tube except at the end of the cycles.

In this technique, a single stranded oligonucleotide sequence of 20 to 60 bases complementary to a
fragment of the DNA sample belonging to the amplicon, i.e. located between the forward and reverse
primers, is added in the sample. This sequence or probe is characterized by the presence of a 
uorescent
reporter at the 5' end and a quencher at the 3' end, both covalently attached. When the probe is
bound to the DNA sample, the quencher inhibits the 
uorescence of the reporter because of the close
proximity of the two. However, in the elongation step of the PCR, during the DNA synthesis, the Taq
polymerase degrades the probe via the exonuclease and releases the reporter and the quencher, allowing
the 
uorescence to take place in the tube as they separate from each other. The probe takes its name
from this process : Taq polymerase + PacMan.

The measured 
orescence in the reaction tube, using LEDs or laser beams, is proportional to the
number of released reporters and therefore to the accumulation of the DNA template.

Schematic representation of the forward and reverse primer s, the amplicon and the
TaqMan probe.

4.2 The plugin interface

The TaqMan probes interface consists of three tabs. One enters the DNA sequence of the sample in
the �rst tab (the DNA sequence of the sample is referred as thereference sequence in the rest of the
User's Guide). One speci�es the parameters for the prediction in the second tab. Once the prediction is
completed, a third tab displays the results.

4.2.1 The \Sequence" tab

In this tab, one enters the reference DNA sequence either by typing or pasting it, or importing it from a
�le with the Open item of the File menu of the plugin, or using the Search sequencesitem of the Tools
menu of the plugin to import a sequence from the Internet, currently from the NCBI server. This tool is
explained in the sectionSequence Search, on page69.
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The Sequence tab of the TaqMan plugin interface.

The format of the imported reference sequence can be one of the following:

FASTA . This is a simple text-based format in which a sequence de�nition is preceded by a title or
comment line starting with the greater-than symbol (' > ').

GenBank is a text-based format containing annotations for the database produced by the National
Center for Biotechnology Information (NCBI).

EMBL is the text-based format developed by the European Molecular Biology Laboratory.

Text . Only valid symbols from the �le are kept, i.e. A, C, G, T, and t he ambiguous characters as
de�ned by IUPAC.

Likewise the Text format, the other formats support ambiguous symbols.

By default, the prediction is performed on the whole sequence. However, it is possible to de�ne or
exclude a range or a set of ranges by checking theLimit the prediction on speci�c sequence regionoption
at the bottom of the sequence tab, additional options will then appear as shown on the next Figure.

It is possible to limit the prediction on speci�c regions of t he sequence or to exclude
speci�c regions of the sequence from the prediction.

These additional options are:

Using base range. A range or a set of ranges separated by semi-colon can be speci�ed.

Using sequence annotation(s). The set of ranges are de�ned by a speci�c annotation.

Exclude from the prediction. The set of ranges de�ned on the left is excluded from the predic-
tion.

NOTE : The predicted amplicons will be totally included in a region or in other words the predicted
amplicons will not overlap adjacent regions.

NOTE : The Rangegroup of the Parameterstab can also be used to �ne-tune the location of the
primers.
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4.2.2 The \Parameters" tab

This tab speci�es all the parameters for the prediction. The parameters are gathered in four groups :
General, Advanced, Filters, and Range. Seex4.4 for a detailed description of the parameters.

Under the Generalgroup are listed parameters such as the oligonucleotide concentration as well as
the salt concentrations in the sample but also the required features of the primers and the amplicon.

The parameters in theAdvancedgroup are used to select on the one hand the theoretical methods to
estimate the �G of formation of homoduplex and heteroduplex as well as the methods to compute
the melting temperature (T m ) for the primers, the amplicon and the probe; and on the otherhand
the requirements about the selectivity of the primers (alsoknown as the unicity1 of the solutions for
the primers) and the criteria to discard primers, pairs of primers and probes based on the presence
of a secondary structure.

The activation and deactivation of �lters is done in the Filters group. For example, if the �lter
Length limits for the primers is activated, the software will discard potential primers based on the
length limits given by the Min length and Max lengthprimer parameters of the Generalgroup. On
the other hand, if the �lter is turned o�, those parameters ar e deactivated and the software will
not use them to discard potential primers during the prediction.

In the Rangegroup, it is possible to specify explicitly where the forward and reverse primers and
the probes will be generated. It is important that the range herein entered must be compatible
with the regions speci�ed in the Sequencetab.

The Parameters tab of the Taqman plugin interface (General) .

1The unicity tests ensure that the solutions are unique on the reference sequence.

BioXpress User Guide Version 1.1



28 CHAPTER 4. THE \TAQMAN PROBES" PLUGIN

The Parameters tab of the Taqman plugin interface (Advanced ).

The Parameters tab of the Taqman plugin interface (Filters) .
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The Parameters tab of the Taqman plugin interface (Range).

It is possible to import and export the set of parameters for subsequent use with the Import and
Export buttons. In addition, one can set the current parameter selection as the default one for the next
PCR task with the Set as defaultbutton. Finally, one can reset the values to the BioXpr default values by
clicking the Reset to BioXpr defaultbutton. The prediction starts by clicking the Start predictionbutton
or the button in the tool bar ( ). A window opens and shows the state of completion of the prediction.

The Prediction is complete. You can view
the statistics for each �lter by clicking on
the corresponding button.

Once the prediction is complete, the results are displayed in the Resultstab. The statistics for each
�lter, i.e. the number of sequences passing through the �lters, are available by clicking theView statistics
button. They are also available via the item Statistics of the View menu.

The statistics are of particular interest especially when the prediction does not deliver any results.
You can easily �gure out the parameters responsible for discarding too many solutions and modify their
values accordingly.
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The statistics for the prediction.

4.2.3 The \Results" tab

This tab is divided into two parts. The lower table lists all t he results of the prediction whereas in the
upper part selected solutions are graphically visualized.The color of a solution is rating dependent :
from bright green (highest rating) to bright red (lowest rat ing). Please note that the rating is not a
measure of the likelihood of success of the experiment with the corresponding solution but a measure of
the relevance of the solution to the parameters entered for the prediction. Each solution consists of a
forward primer (FP), a reverse primer (RP), the resulting amplicon and a probe (TP).

Toolbar

Graphical visualization of the selected solutions

Table with the solutions of the prediction

The Results tab of the Taqman plugin interface.

The columns in the table can be (a) resized by moving the mouseon the right edge of title, (b)
rearranged by dragging and, (c) hidden or shown via the button ( ) available in the right top corner of
the table. The button shows a drop down menu with the headers of the columns of the table. A brief
description is given below.
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Columns of the table for the solutions of a
prediction

Checked Mark the solution.
ID ID of the solution.
Rating Total rating of the solution.
FP/RP/
Amplicon/
TP Rating

Rating of the Forward/Reverse primers,
the amplicon or the probe .

FP/RP/TP
Start

5' position of the Forward/Reverse
Primer or TaqMan Probe.

FP/RP/TP
length

Length of the Forward/Reverse Primer
or TaqMan Probe.

FP/RP/TP
T m

Melting temperature of the For-
ward/Reverse Primer or TaqMan
Probe.

FP/RP/TP
%GC

% GC of the Forward/Reverse Primer or
TaqMan Probe.

FP/RP/TP Forward/Reverse Primer or TaqMan
Probe sequence.

Amplicon
length

The length of the amplicon.

Amplicon T a Temperature of annealing.
Horizontal
Scroll

Enable/disable the horizontal scrolling of
the table.

Pack All
Columns

Resize the width of the columns to �t
best their contents.

Pack Se-
lected Col-
umn

Resize the width of the selected column.
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4.2.4 Menus and tool bar.

The commands in theFile menu are described below.

Command in the
File menu

Description

Open sequence Open a sequence �le in the current
window or a previously saved pre-
diction in an new window.

Save Save the prediction.
Save as Save the prediction under another

�le name.
Export as Export the solutions of the predic-

tion in a text �le, CSV �le, or Excel
�le.

Create a report Generate a report with the selected
solutions. The report is viewed in
a separate window and can be ex-
ported as a PDF �le or directly
printed. It is possible to customize
the content and the presentation,
export and import the resulting
con�guration, make it as the de-
fault or even reset to the initial con-
�guration.

Close Close the current window.

The Edit menu depends on the active tab. It gathers the commands for copying the selected solutions,
search for sub-sequences or navigate throughout the reference sequence, ... The description of each of the
commands is given in the following table.

Command in the
Edit menu.

Description

Cut In the Sequence tab, cut the selec-
tion into the clipboard.

Copy In the Sequence tab, copy the selec-
tion into the clipboard. In the Re-
sult tab, copy the content of the se-
lected solutions into the clipboard.

Paste In the Sequence tab, replace the se-
lection by the content of the clip-
board.

Preferences... Change the preferences for display-
ing the di�erent elements.

Search on sequence... Search in the reference sequence a
sub-sequence or an annotation, ...
It is important to note that the re-
sults of the search process are cu-
mulative, i.e. they can be used to
highlight di�erent parts of the se-
quences.

Clean search Reset the search results.
Go to base Move the view to the given base.
Go to start Move the view to the 5' end of the

sequence.
Go to end Move the view to the 3' end of the

sequence.

The Tools menu lists the available tools on the software.
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Command in the
Tools menu.

Description

Property calculator For a selected solution it is possi-
ble to compute properties such as
the GC content, the melting tem-
perature, ... You have access to the
Property Calculator via the Tools
menu of the plugin or by right click-
ing either on a primer in the upper
graphical representation visualiza-
tion or on a solution in the lower ta-
ble. This tool is explained in section
Property Calculator, on page 67.

Sequence Search This tool allows the search of a spe-
ci�c sequence in several databases
of the NCBI web site by entering
criteria and download it in the Se-
quence tab. This tool is explained
in section Search sequence, on page
69.

The Selectionmenu is only active within the Results tab. The description of each of the commands
is given in the following table.

Command in the
Selection menu.

Description

Select all solutions Select all solutions.
Unselect all solutions Clear the selection.
Select checked Select all the solutions marked to

be kept.
Invert selection Inverse the selection.
Check all selected The selected solutions will be

marked to be kept.
Uncheck all selected The 'keep' status of the selected so-

lutions will be turned o�.
Invert check state For the selected solutions, inverse

the keep status.

The type of visualization and the amount of information shown can be tuned with the following
options, both available from the View menu or from the tool bar.
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Command in the
View menu.

Description

Show statistics Open a dialog box with the statis-
tics of the prediction.

Bases display Switch between two views of the ref-
erence sequence : in the �rst one,
each base is represented by its sym-
bol whereas in the second one, the
whole sequence is viewed as a line.

Multiline display For a long sequence, split the repre-
sentation of the sequence in several
lines on top of each others.

Properties Show the properties of the selected
solutions.

Heteroduplexes Show the potential heteroduplexes
between the primers of the selected
solutions.

Zoom in Zoom in the view
Zoom out Zoom out the view
Center view Move the view to the center of the

sequence.
Increase base size Increase the size of a base.
Decrease base size Decrease the size of a base.
Switch on the view of
both the tags and the
masks.
Sequence annota-
tion/Show tags

Switch on and o� the display of the
tags.

Sequence annota-
tion/Show masks

Switch on and o� the display of the
masks.

Sequence annota-
tion/Hide annota-
tions

Switch o� the display of both the
tags and the masks.

Export view as... Export the current view as an im-
age �le.

BioXpress User Guide Version 1.1



4.3. PROPERTIES AND HETERODUPLEXES OF A SOLUTION 35

4.3 Properties and Heteroduplexes of a solution

[plugin menu]View > Properties & View > Heteroduplexes

During the prediction, properties and structures for the primers, the amplicons or pairs of primers and
the probes are computed. To view the properties or the heteroduplexes of a primer or an amplicon or a
probe, you may right click either in table or in the graphical visualization, or select the Propertiesitem
of the View menu. You can navigate through the selected solutions with the navigation buttons. You
can also print the properties of the current solution with th e Print button. Properties and structures are
also available via the reports.

Navigation buttons

The properties of a solution. Use the navigation buttons to i terate through the selected
solutions.

Navigation buttons

The heteroduplexes of a solution. Use the navigation button s to iterate through the
selected solutions.
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4.4 Description of the parameters

Oligo concentration : concentration of oligonucleotide in the solution, in nM (10� 9M).
[General/Reaction conditions]

Salt concentration (Na+ ) : concentration of monovalent salt in the solution, in mM (10� 3M).
[General/Reaction conditions]

Salt concentration (Mg2+ ) : concentration of divalent salt in the solution, in mM (10 � 3M).
[General/Reaction conditions]

Min length : minimal length, in bp, for the primers, the amplicons, or the probes.
[General/Primer ; General/Amplicon ; General/TaqMan probe]

Max length : maximal length, in bp, for the primers, the amplicons, or the probes.
[General/Primer ; General/Amplicon ; General/TaqMan probe]

Min T m : minimal melting temperature, in � C, for the primers, the amplicons, or the probes.
[General/Primer ; General/Amplicon ; General/TaqMan probe]

Max Tm : maximal melting temperature, in � C, for the primers, the amplicons, or the probes.
[General/Primer ; General/Amplicon ; General/TaqMan probe]

Min GC : minimal content in G/C bases, in percentage, for the primers or the probes.
[General/Primer ; General/TaqMan probe]

Max GC : maximal content in G/C bases, in percentage, for the primers or the probes.
[General/Primer ; General/TaqMan probe]

Min num of GC on 3' end : minimal occurrence of G/C bases in the 5 last bases for the primers.
[General/Primer]

Max num of GC on 3' end : maximal occurrence of G/C bases in the 5 last bases end for the
primers or the probes.
[General/Primer ; General/TaqMan probe]

Max num of repeated G or C: maximal occurrence of repeated G or C for the primers or the probes.
[General/Primer ; General/TaqMan probe]

Max num of repeated A or T : maximal occurrence of repeated A or T for the primers or the probes.
[General/Primer ; General/TaqMan probe]

Max num repeated dinucleotides: maximal occurrence of repeated dinucleotides for the primers or
the probes.
[General/Primer ; General/TaqMan probe]

More C than G in probe : when checked, the TaqMan probe must have more C bases than G bases.
[General/TaqMan probe]

G or C at 3' end : if checked, the last residue for the primers or the TaqMan probes must be a G
or a C.
[General/Primer ; General/TaqMan probe]

Not G at 5' end : when checked, the TaqMan probe must not have a G base at the 5'end.
[General/TaqMan probe]

Max ambiguous bases: Maximal occurrence of ambiguous bases for the amplicon, excepted the
primers.
[General/Amplicon]

Max Tm di�erence between the primers : Maximal di�erence between the Tm for the primers
de�ning the amplicon, in � C.
[General/Amplicon]
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Min T a : Minimal annealing temperature, in � C.
[General/Amplicon]

Max Ta : Maximal annealing temperature, in � C.
[General/Amplicon]

Min T m di�erence between primers and probe: Minimal di�erence between the T m for the primers
de�ning the amplicon and the T m for the TaqMan probe, in � C.
[General/Amplicon]

� G method : list of available theoretical methods to evaluate the �G.
[Advanced/Method]

Tm method for primers/amplicons/TaqMan probes : list of available theoretical methods to evaluate
the Tm for the primers, amplicons, and probes.
[Advanced/Method]

Max consecutive matches: Maximal number of consecutive matches, in bp, between a primer and
the DNA sequence before considering a binding.
[Advanced/Primer unicity]

Max 3' consecutive matches: Maximal number of consecutive matches, in bp, between the 3' end
of a primer and the DNA sequence before considering a binding.
[Advanced/Primer unicity]

Max percent of matches: Maximal percentage of matches between a primer and the DNA sequence
before considering a binding.
[Advanced/Primer unicity]

Check using the Amplify method: Check the binding of a primer with the DNA sequence with the
Amplify method.
[Advanced/Primer unicity]

Min � G (probe) Hairpin : Discard primers or probes forming a hairpin with an energy below the
given �G in kCal/mol.
[Advanced/Primer secondary structure ; Advanced/TaqMan probe secondary structure]

Min � G Hairpin in 3' : Discard primers forming a 3' hairpin with an energy below the given �G
in kCal/mol.
[Advanced/Primer secondary structure]

Min � G (probe) homoduplex : Discard primers or probes forming a homoduplex with an energy
below the given �G in kCal/mol.
[Advanced/Primer secondary structure ; Advanced/TaqMan probe secondary structure]

Min � G 3' homoduplex : Discard primers forming a 3' homoduplex with an energy below the given
�G in kCal/mol.
[Advanced/Primer secondary structure]

Max number of hydrogen bonds: Discard primers forming homoduplex or heteroduplex having a
number of hydrogen bonds above the given limit.
[Advanced/Primer secondary structure ; Advanced/Pair of primers secondary structure]

Min � G heteroduplex: Discard primers forming heteroduplex with an energy belowthe given �G
in kCal/mol.
[Advanced/Pair of primers secondary structure]

Min � G heteroduplex in 3' : Discard primers forming a heteroduplex in 3' with an energybelow
the given �G in kCal/mol.
[Advanced/Pair of primers secondary structure]

BioXpress User Guide Version 1.1



38 CHAPTER 4. THE \TAQMAN PROBES" PLUGIN

BioXpress User Guide Version 1.1



Chapter 5

The \TaqMan MGB probes" plugin

5.1 Introduction

The addition of a minor groove binder (MGB) group to a DNA prob e enables the formation of extremely
stables duplexes with single-stranded DNA targets. An immediate application is the use of shorter
probes in real-time PCR. With respect to the unmodi�ed DNA pr obes, MGB probes show higher melting
temperature and increased speci�city, especially when a mismatch occurs in the MGB region of the duplex
probe-target. Beside the addition of the MGB group to the DNA probe, the TaqMan MGB procedure is
equivalent to the simple TaqMan procedure described beforein section IV. a. , on page 35. There are
several available MGB groups, however, the software only considers currently the 3' CDPI3 MGB group.

Schematic representation of the forward and reverse primer s, the amplicon and the
TaqMan MGB probe.

5.2 The plugin interface

The TaqMan MGB probes interface consists of three tabs. One enters the DNA sequence of the sample
in the �rst tab (the DNA sequence of the sample is referred as the reference sequence in the rest of the
User's Guide). One speci�es the parameters for the prediction in the second tab. Once the prediction is
completed, a third tab displays the results.

5.2.1 The \Sequence" tab

In this tab, one enters the reference DNA sequence either by typing or pasting it, or importing it from a
�le with the Open item of the File menu of the plugin, or using the Search sequencesitem of the Tools
menu of the plugin to import a sequence from the Internet, currently from the NCBI server. This tool is
explained in the sectionSequence Search, on page69.
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The Sequence tab of the TaqMan MGB plugin interface.

The format of the imported reference sequence can be one of the following:

FASTA . This is a simple text-based format in which a sequence de�nition is preceded by a title or
comment line starting with the greater-than symbol (' > ').

GenBank is a text-based format containing annotations for the database produced by the National
Center for Biotechnology Information (NCBI).

EMBL is the text-based format developed by the European Molecular Biology Laboratory.

Text . Only valid symbols from the �le are kept, i.e. A, C, G, T, and t he ambiguous characters as
de�ned by IUPAC.

Likewise the Text format, the other formats support ambiguous symbols.

By default, the prediction is performed on the whole sequence. However, it is possible to de�ne or
exclude a range or a set of ranges by checking theLimit the prediction on speci�c sequence regionoption
at the bottom of the sequence tab, additional options will then appear as shown on the next Figure.

It is possible to limit the prediction on speci�c regions of t he sequence or to exclude
speci�c regions of the sequence from the prediction.

These additional options are:

Using base range. A range or a set of ranges separated by semi-colon can be speci�ed.

Using sequence annotation(s). The set of ranges are de�ned by a speci�c annotation.

Exclude from the prediction. The set of ranges de�ned on the left is excluded from the predic-
tion.

NOTE : The predicted amplicons will be totally included in a region or in other words the predicted
amplicons will not overlap adjacent regions.

BioXpress User Guide Version 1.1



5.2. THE PLUGIN INTERFACE 41

NOTE : The Range group of the Parameterstab can also be used to �ne-tune the location of the
primers.

5.2.2 The \Parameters" tab

This tab speci�es all the parameters for the prediction. The parameters are gathered in four groups :
General, Advanced, Filters, and Range. Seex5.4 for a detailed description of the parameters.

Under the Generalgroup are listed parameters such as the oligonucleotide concentration as well as
the salt concentrations in the sample but also the required features of the primers and the amplicon.

The parameters in theAdvancedgroup are used to select on the one hand the theoretical methods to
estimate the �G of formation of homoduplex and heteroduplex as well as the methods to compute
the melting temperature (T m ) for the primers, the amplicon and the probe; and on the otherhand
the requirements about the selectivity of the primers (alsoknown as the unicity1 of the solutions for
the primers) and the criteria to discard primers, pairs of primers and probes based on the presence
of a secondary structure.

The activation and deactivation of �lters is done in the Filters group. For example, if the �lter
Length limits for the primers is activated, the software will discard potential primers based on the
length limits given by the Min length and Max lengthprimer parameters of the Generalgroup. On
the other hand, if the �lter is turned o�, those parameters ar e deactivated and the software will
not use them to discard potential primers during the prediction.

In the Rangegroup, it is possible to specify explicitly where the forward and reverse primers and
the probes will be generated. It is important that the range herein entered must be compatible
with the regions speci�ed in the Sequencetab.

The Parameters tab of the Taqman MGB plugin interface (Gener al).

1The unicity tests ensure that the solutions are unique on the reference sequence.
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The Parameters tab of the Taqman MGB plugin interface (Advan ced).

The Parameters tab of the Taqman MGB plugin interface (Filte rs).
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The Parameters tab of the Taqman MGB plugin interface (Range ).

It is possible to import and export the set of parameters for subsequent use with the Import and
Export buttons. In addition, one can set the current parameter selection as the default one for the next
PCR task with the Set as defaultbutton. Finally, one can reset the values to the BioXpr default values by
clicking the Reset to BioXpr defaultbutton. The prediction starts by clicking the Start predictionbutton
or the button in the tool bar ( ). A window opens and shows the state of completion of the prediction.

The Prediction is complete. You can view
the statistics for each �lter by clicking on
the corresponding button.

Once the prediction is complete, the results are displayed in the Resultstab. The statistics for each
�lter, i.e. the number of sequences passing through the �lters, are available by clicking theView statistics
button. They are also available via the item Statistics of the View menu.

The statistics are of particular interest especially when the prediction does not deliver any results.
You can easily �gure out the parameters responsible for discarding too many solutions and modify their
values accordingly.

BioXpress User Guide Version 1.1



44 CHAPTER 5. THE \TAQMAN MGB PROBES" PLUGIN

The statistics for the prediction.

5.2.3 The \Results" tab

This tab is divided into two parts. The lower table lists all t he results of the prediction whereas in the
upper part selected solutions are graphically visualized.The color of a solution is rating dependent :
from bright green (highest rating) to bright red (lowest rat ing). Please note that the rating is not a
measure of the likelihood of success of the experiment with the corresponding solution but a measure of
the relevance of the solution to the parameters entered for the prediction. Each solution consists of a
forward primer (FP), a reverse primer (RP), the resulting amplicon and a probe (TP).

Toolbar

Graphical visualization of the selected solutions

Table with the solutions of the prediction

The Results tab of the Taqman MGB plugin interface.

The columns in the table can be (a) resized by moving the mouseon the right edge of title, (b)
rearranged by dragging and, (c) hidden or shown via the button ( ) available in the right top corner of
the table. The button shows a drop down menu with the headers of the columns of the table. A brief
description is given below.
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Columns of the table for the solutions of a
prediction

Checked Mark the solution.
ID ID of the solution.
Rating Total rating of the solution.
FP/RP/
Amplicon/
TP Rating

Rating of the Forward/Reverse primers,
the amplicon or the probe .

FP/RP/TP
Start

5' position of the Forward/Reverse
Primer or TaqMan Probe.

FP/RP/TP
length

Length of the Forward/Reverse Primer
or TaqMan Probe.

FP/RP/TP
T m

Melting temperature of the For-
ward/Reverse Primer or TaqMan
MGB Probe.

FP/RP/TP
%GC

% GC of the Forward/Reverse Primer or
TaqMan Probe.

FP/RP/TP Forward/Reverse Primer or TaqMan
Probe sequence.

Amplicon
length

The length of the amplicon.

Amplicon T a Temperature of annealing.
Horizontal
Scroll

Enable/disable the horizontal scrolling of
the table.

Pack All
Columns

Resize the width of the columns to �t
best their contents.

Pack Se-
lected Col-
umn

Resize the width of the selected column.
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5.2.4 Menus and tool bar.

The commands in theFile menu are described below.

Command in the
File menu

Description

Open sequence Open a sequence �le in the current
window or a previously saved pre-
diction in an new window.

Save Save the prediction.
Save as Save the prediction under another

�le name.
Export as Export the solutions of the predic-

tion in a text �le, CSV �le, or Excel
�le.

Create a report Generate a report with the selected
solutions. The report is viewed in
a separate window and can be ex-
ported as a PDF �le or directly
printed. It is possible to customize
the content and the presentation,
export and import the resulting
con�guration, make it as the de-
fault or even reset to the initial con-
�guration.

Close Close the current window.

The Edit menu depends on the active tab. It gathers the commands for copying the selected solutions,
search for sub-sequences or navigate throughout the reference sequence, ... The description of each of the
commands is given in the following table.

Command in the
Edit menu.

Description

Cut In the Sequence tab, cut the selec-
tion into the clipboard.

Copy In the Sequence tab, copy the selec-
tion into the clipboard. In the Re-
sult tab, copy the content of the se-
lected solutions into the clipboard.

Paste In the Sequence tab, replace the se-
lection by the content of the clip-
board.

Preferences... Change the preferences for display-
ing the di�erent elements.

Search on sequence... Search in the reference sequence a
sub-sequence or an annotation, ...
It is important to note that the re-
sults of the search process are cu-
mulative, i.e. they can be used to
highlight di�erent parts of the se-
quences.

Clean search Reset the search results.
Go to base Move the view to the given base.
Go to start Move the view to the 5' end of the

sequence.
Go to end Move the view to the 3' end of the

sequence.

The Tools menu lists the available tools on the software.
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Command in the
Tools menu.

Description

Property calculator For a selected solution it is possi-
ble to compute properties such as
the GC content, the melting tem-
perature, ... You have access to the
Property Calculator via the Tools
menu of the plugin or by right click-
ing either on a primer in the upper
graphical representation visualiza-
tion or on a solution in the lower ta-
ble. This tool is explained in section
Property Calculator, on page 67.

Sequence Search This tool allows the search of a spe-
ci�c sequence in several databases
of the NCBI web site by entering
criteria and download it in the Se-
quence tab. This tool is explained
in section Search sequence, on page
69.

The Selectionmenu is only active within the Results tab. The description of each of the commands
is given in the following table.

Command in the
Selection menu.

Description

Select all solutions Select all solutions.
Unselect all solutions Clear the selection.
Select checked Select all the solutions marked to

be kept.
Invert selection Inverse the selection.
Check all selected The selected solutions will be

marked to be kept.
Uncheck all selected The 'keep' status of the selected so-

lutions will be turned o�.
Invert check state For the selected solutions, inverse

the keep status.

The type of visualization and the amount of information shown can be tuned with the following
options, both available from the View menu or from the tool bar.
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Command in the
View menu.

Description

Show statistics Open a dialog box with the statis-
tics of the prediction.

Bases display Switch between two views of the ref-
erence sequence : in the �rst one,
each base is represented by its sym-
bol whereas in the second one, the
whole sequence is viewed as a line.

Multiline display For a long sequence, split the repre-
sentation of the sequence in several
lines on top of each others.

Properties Show the properties of the selected
solutions.

Heteroduplexes Show the potential heteroduplexes
between the primers of the selected
solutions.

Zoom in Zoom in the view
Zoom out Zoom out the view
Center view Move the view to the center of the

sequence.
Increase base size Increase the size of a base.
Decrease base size Decrease the size of a base.
Switch on the view of
both the tags and the
masks.
Sequence annota-
tion/Show tags

Switch on and o� the display of the
tags.

Sequence annota-
tion/Show masks

Switch on and o� the display of the
masks.

Sequence annota-
tion/Hide annota-
tions

Switch o� the display of both the
tags and the masks.

Export view as... Export the current view as an im-
age �le.
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5.3 Properties and Heteroduplexes of a solution

[plugin menu]View > Properties & View > Heteroduplexes

During the prediction, properties and structures for the primers, the amplicons or pairs of primers and
the probes are computed. To view the properties or the heteroduplexes of a primer or an amplicon or a
probe, you may right click either in table or in the graphical visualization, or select the Propertiesitem
of the View menu. You can navigate through the selected solutions with the navigation buttons. You
can also print the properties of the current solution with th e Print button. Properties and structures are
also available via the reports.

Navigation buttons

The properties of a solution. Use the navigation buttons to i terate through the selected
solutions.

Navigation buttons

The heteroduplexes of a solution. Use the navigation button s to iterate through the
selected solutions.
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5.4 Description of the parameters

Oligo concentration : concentration of oligonucleotide in the solution, in nM (10� 9M).
[General/Reaction conditions]

Salt concentration (Na+ ) : concentration of monovalent salt in the solution, in mM (10� 3M).
[General/Reaction conditions]

Salt concentration (Mg2+ ) : concentration of divalent salt in the solution, in mM (10 � 3M).
[General/Reaction conditions]

Min length : minimal length, in bp, for the primers, the amplicons, or the probes.
[General/Primer ; General/Amplicon ; General/TaqMan probe]

Max length : maximal length, in bp, for the primers, the amplicons, or the probes.
[General/Primer ; General/Amplicon ; General/TaqMan probe]

Min T m : minimal melting temperature, in � C, for the primers, the amplicons, or the probes.
[General/Primer ; General/Amplicon ; General/TaqMan probe]

Max Tm : maximal melting temperature, in � C, for the primers, the amplicons, or the probes.
[General/Primer ; General/Amplicon ; General/TaqMan probe]

Min GC : minimal content in G/C bases, in percentage, for the primers or the probes.
[General/Primer ; General/TaqMan probe]

Max GC : maximal content in G/C bases, in percentage, for the primers or the probes.
[General/Primer ; General/TaqMan probe]

Min num of GC on 3' end : minimal occurrence of G/C bases in the 5 last bases for the primers.
[General/Primer]

Max num of GC on 3' end : maximal occurrence of G/C bases in the 5 last bases end for the
primers or the probes.
[General/Primer ; General/TaqMan probe]

Max num of repeated G or C: maximal occurrence of repeated G or C for the primers or the probes.
[General/Primer ; General/TaqMan probe]

Max num of repeated A or T : maximal occurrence of repeated A or T for the primers or the probes.
[General/Primer ; General/TaqMan probe]

Max num repeated dinucleotides: maximal occurrence of repeated dinucleotides for the primers or
the probes.
[General/Primer ; General/TaqMan probe]

More C than G in probe : when checked, the TaqMan probe must have more C bases than G bases.
[General/TaqMan probe]

G or C at 3' end : if checked, the last residue for the primers or the TaqMan probes must be a G
or a C.
[General/Primer ; General/TaqMan probe]

Not G at 5' end : when checked, the TaqMan probe must not have a G base at the 5'end.
[General/TaqMan probe]

Max ambiguous bases: Maximal occurrence of ambiguous bases for the amplicon, excepted the
primers.
[General/Amplicon]

Max Tm di�erence between the primers : Maximal di�erence between the Tm for the primers
de�ning the amplicon, in � C.
[General/Amplicon]
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Min T a : Minimal annealing temperature, in � C.
[General/Amplicon]

Max Ta : Maximal annealing temperature, in � C.
[General/Amplicon]

Min T m di�erence between primers and probe: Minimal di�erence between the T m for the primers
de�ning the amplicon and the T m for the TaqMan probe, in � C.
[General/Amplicon]

� G method : list of available theoretical methods to evaluate the �G.
[Advanced/Method]

Tm method for primers/amplicons/TaqMan probes : list of available theoretical methods to evaluate
the Tm for the primers, amplicons, and probes.
[Advanced/Method]

Max consecutive matches: Maximal number of consecutive matches, in bp, between a primer and
the DNA sequence before considering a binding.
[Advanced/Primer unicity]

Max 3' consecutive matches: Maximal number of consecutive matches, in bp, between the 3' end
of a primer and the DNA sequence before considering a binding.
[Advanced/Primer unicity]

Max percent of matches: Maximal percentage of matches between a primer and the DNA sequence
before considering a binding.
[Advanced/Primer unicity]

Check using the Amplify method: Check the binding of a primer with the DNA sequence with the
Amplify method.
[Advanced/Primer unicity]

Min � G (probe) Hairpin : Discard primers or probes forming a hairpin with an energy below the
given �G in kCal/mol.
[Advanced/Primer secondary structure ; Advanced/TaqMan probe secondary structure]

Min � G Hairpin in 3' : Discard primers forming a 3' hairpin with an energy below the given �G
in kCal/mol.
[Advanced/Primer secondary structure]

Min � G (probe) homoduplex : Discard primers or probes forming a homoduplex with an energy
below the given �G in kCal/mol.
[Advanced/Primer secondary structure ; Advanced/TaqMan probe secondary structure]

Min � G 3' homoduplex : Discard primers forming a 3' homoduplex with an energy below the given
�G in kCal/mol.
[Advanced/Primer secondary structure]

Max number of hydrogen bonds: Discard primers forming homoduplex or heteroduplex having a
number of hydrogen bonds above the given limit.
[Advanced/Primer secondary structure ; Advanced/Pair of primers secondary structure]

Min � G heteroduplex: Discard primers forming heteroduplex with an energy belowthe given �G
in kCal/mol.
[Advanced/Pair of primers secondary structure]

Min � G heteroduplex in 3' : Discard primers forming a heteroduplex in 3' with an energybelow
the given �G in kCal/mol.
[Advanced/Pair of primers secondary structure]
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Chapter 6

The \Molecular Beacon" plugin

6.1 Introduction

In the Molecular Beacon real-time PCR technique, the probe is an hairpin shaped molecule, or in other
words it forms a stem-and-loop structure. The Molecular Beacon probe is designed so that the loop is
complementary to the target sequence and the stem allows theopening of the hairpin while hybridizing on
the DNA sample, i.e. the hybrid form is more stable than the stem form. A 
uorophore and a quencher
are covalently linked to the end of the arms or tails. Contrary to the TaqMan probe, the Molecular
Beacon probe 
uoresces when hybridized and is dark when freein solution. Another important di�erence
with the TaqMan technique is that the Molecular Beacon probes are not consumed during the PCR
reaction. Last but not least, Molecular Beacon probes are very speci�c. This is due to the equilibrium
between the hybridized and stem states. A single nucleotidemismatch can be su�cient to favor the stem
form of the probe and therefore the probe remains dark.

Schematic representation of the forward and reverse primer s, the amplicon and the
Molecular Beacon probe.

6.2 The plugin interface

The Molecular Beacon interface consists of three tabs. One enters the DNA sequence of the sample in
the �rst tab (the DNA sequence of the sample is referred as thereference sequence in the rest of this
User's Guide). One speci�es the parameters for the prediction in the second tab. Once the prediction is
completed, a third tab displays the results.

6.2.1 The \Sequence" tab

In this tab, one enters the reference DNA sequence either by typing or pasting it, or importing it from a
�le with the Open item of the File menu of the plugin, or using the Search sequencesitem of the Tools
menu of the plugin to import a sequence from the Internet, currently from the NCBI server. This tool is
explained in the sectionSequence Search, on page69.
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The Sequence tab of the Molecular Beacon plugin interface.

The format of the imported reference sequence can be one of the following:

FASTA . This is a simple text-based format in which a sequence de�nition is preceded by a title or
comment line starting with the greater-than symbol (' > ').

GenBank is a text-based format containing annotations for the database produced by the National
Center for Biotechnology Information (NCBI).

EMBL is the text-based format developed by the European Molecular Biology Laboratory.

Text . Only valid symbols from the �le are kept, i.e. A, C, G, T, and t he ambiguous characters as
de�ned by IUPAC.

Likewise the Text format, the other formats support ambiguous symbols.

By default, the prediction is performed on the whole sequence. However, it is possible to de�ne or
exclude a range or a set of ranges by checking theLimit the prediction on speci�c sequence regionoption
at the bottom of the sequence tab, additional options will then appear as shown on the next Figure.

It is possible to limit the prediction on speci�c regions of t he sequence or to exclude
speci�c regions of the sequence from the prediction.

These additional options are:

Using base range. A range or a set of ranges separated by semi-colon can be speci�ed.

Using sequence annotation(s). The set of ranges are de�ned by a speci�c annotation.

Exclude from the prediction. The set of ranges de�ned on the left is excluded from the predic-
tion.
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NOTE : The predicted amplicons will be totally included in a region or in other words the predicted
amplicons will not overlap adjacent regions.

NOTE : The Range group of the Parameterstab can also be used to �ne-tune the location of the
primers.

6.2.2 The \Parameters" tab

This tab speci�es all the parameters for the prediction. The parameters are gathered in four groups :
General, Advanced, Filters, and Range. Seex6.4 for a detailed description of the parameters.

Under the Generalgroup are listed parameters such as the oligonucleotide concentration as well as
the salt concentrations in the sample but also the required features of the primers and the amplicon.

The parameters in theAdvancedgroup are used to select on the one hand the theoretical methods to
estimate the �G of formation of homoduplex and heteroduplex as well as the methods to compute
the melting temperature (T m ) for the primers, the amplicon and the probe; and on the otherhand
the requirements about the selectivity of the primers (alsoknown as the unicity1 of the solutions for
the primers) and the criteria to discard primers, pairs of primers and probes based on the presence
of a secondary structure.

The activation and deactivation of �lters is done in the Filters group. For example, if the �lter
Length limits for the primers is activated, the software will discard potential primers based on the
length limits given by the Min length and Max lengthprimer parameters of the Generalgroup. On
the other hand, if the �lter is turned o�, those parameters ar e deactivated and the software will
not use them to discard potential primers during the prediction.

In the Rangegroup, it is possible to specify explicitly where the forward and reverse primers and
the probes will be generated. It is important that the range herein entered must be compatible
with the regions speci�ed in the Sequencetab.

The Parameters tab of the Molecular Beacon plugin interface (General).

1The unicity tests ensure that the solutions are unique on the reference sequence.
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The Parameters tab of the Molecular Beacon plugin interface (Advanced).

The Parameters tab of the Molecular Beacon plugin interface (Filters).
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The Parameters tab of the Molecular Beacon plugin interface (Range).

It is possible to import and export the set of parameters for subsequent use with the Import and
Export buttons. In addition, one can set the current parameter selection as the default one for the next
PCR task with the Set as defaultbutton. Finally, one can reset the values to the BioXpr default values by
clicking the Reset to BioXpr defaultbutton. The prediction starts by clicking the Start predictionbutton
or the button in the tool bar ( ). A window opens and shows the state of completion of the prediction.

The Prediction is complete. You can view
the statistics for each �lter by clicking on
the corresponding button.

Once the prediction is complete, the results are displayed in the Resultstab. The statistics for each
�lter, i.e. the number of sequences passing through the �lters, are available by clicking theView statistics
button. They are also available via the item Statistics of the View menu.

The statistics are of particular interest especially when the prediction does not deliver any results.
You can easily �gure out the parameters responsible for discarding too many solutions and modify their
values accordingly.
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The statistics for the prediction.

6.2.3 The \Results" tab

This tab is divided into two parts. The lower table lists all t he results of the prediction whereas in the
upper part selected solutions are graphically visualized.The color of a solution is rating dependent :
from bright green (highest rating) to bright red (lowest rat ing). Please note that the rating is not a
measure of the likelihood of success of the experiment with the corresponding solution but a measure of
the relevance of the solution to the parameters entered for the prediction. Each solution consists of a
forward primer (FP), a reverse primer (RP), the resulting amplicon and a Beacon probe (BP).

Toolbar

Graphical visualization of the selected solutions

Table with the solutions of the prediction

The Results tab of the Molecular Beacon plugin interface.

The columns in the table can be (a) resized by moving the mouseon the right edge of title, (b)
rearranged by dragging and, (c) hidden or shown via the button ( ) available in the right top corner of
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the table. The button shows a drop down menu with the headers of the columns of the table. A brief
description is given below.

Columns of the table for the solutions of a
prediction

Checked Mark the solution.
ID ID of the solution.
Rating Total rating of the solution.
FP/RP/
Amplicon/
BP Rating

Rating of the Forward/Reverse primers,
the amplicon or the probe .

FP/RP/BP
Start

5' position of the Forward/Reverse
Primer or Molecular Beacon Probe.

FP/RP/BP
length

Length of the Forward/Reverse Primer
or Beacon Probe.

FP/RP/BP
T m

Melting temperature of the For-
ward/Reverse Primer or Molecular
Beacon Probe.

FP/RP/BP
%GC

% GC of the Forward/Reverse Primer or
Beacon Probe.

FP/RP/BP Forward/Reverse Primer or Beacon
Probe sequence.

Amplicon
length

The length of the amplicon.

Amplicon T a Temperature of annealing.
Bp stem
length

Molecular Beacon stem length,

Bp stem Molecular Beacon stem,
Horizontal
Scroll

Enable/disable the horizontal scrolling of
the table.

Pack All
Columns

Resize the width of the columns to �t
best their contents.

Pack Se-
lected Col-
umn

Resize the width of the selected column.

6.2.4 Menus and tool bar.

The commands in theFile menu are described below.
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Command in the
File menu

Description

Open sequence Open a sequence �le in the current
window or a previously saved pre-
diction in an new window.

Save Save the prediction.
Save as Save the prediction under another

�le name.
Export as Export the solutions of the predic-

tion in a text �le, CSV �le, or Excel
�le.

Create a report Generate a report with the selected
solutions. The report is viewed in
a separate window and can be ex-
ported as a PDF �le or directly
printed. It is possible to customize
the content and the presentation,
export and import the resulting
con�guration, make it as the de-
fault or even reset to the initial con-
�guration.

Close Close the current window.

The Edit menu depends on the active tab. It gathers the commands for copying the selected solutions,
search for sub-sequences or navigate throughout the reference sequence, ... The description of each of the
commands is given in the following table.

Command in the
Edit menu.

Description

Cut In the Sequence tab, cut the selec-
tion into the clipboard.

Copy In the Sequence tab, copy the selec-
tion into the clipboard. In the Re-
sult tab, copy the content of the se-
lected solutions into the clipboard.

Paste In the Sequence tab, replace the se-
lection by the content of the clip-
board.

Preferences... Change the preferences for display-
ing the di�erent elements.

Search on sequence... Search in the reference sequence a
sub-sequence or an annotation, ...
It is important to note that the re-
sults of the search process are cu-
mulative, i.e. they can be used to
highlight di�erent parts of the se-
quences.

Clean search Reset the search results.
Go to base Move the view to the given base.
Go to start Move the view to the 5' end of the

sequence.
Go to end Move the view to the 3' end of the

sequence.

The Tools menu lists the available tools on the software.
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Command in the
Tools menu.

Description

Property calculator For a selected solution it is possi-
ble to compute properties such as
the GC content, the melting tem-
perature, ... You have access to the
Property Calculator via the Tools
menu of the plugin or by right click-
ing either on a primer in the upper
graphical representation visualiza-
tion or on a solution in the lower ta-
ble. This tool is explained in section
Property Calculator, on page 67.

Sequence Search This tool allows the search of a spe-
ci�c sequence in several databases
of the NCBI web site by entering
criteria and download it in the Se-
quence tab. This tool is explained
in section Search sequence, on page
69.

The Selectionmenu is only active within the Results tab. The description of each of the commands
is given in the following table.

Command in the
Selection menu.

Description

Select all solutions Select all solutions.
Unselect all solutions Clear the selection.
Select checked Select all the solutions marked to

be kept.
Invert selection Inverse the selection.
Check all selected The selected solutions will be

marked to be kept.
Uncheck all selected The 'keep' status of the selected so-

lutions will be turned o�.
Invert check state For the selected solutions, inverse

the keep status.

The type of visualization and the amount of information shown can be tuned with the following
options, both available from the View menu or from the tool bar.
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Command in the
View menu.

Description

Show statistics Open a dialog box with the statis-
tics of the prediction.

Bases display Switch between two views of the ref-
erence sequence : in the �rst one,
each base is represented by its sym-
bol whereas in the second one, the
whole sequence is viewed as a line.

Multiline display For a long sequence, split the repre-
sentation of the sequence in several
lines on top of each others.

Properties Show the properties of the selected
solutions.

Heteroduplexes Show the potential heteroduplexes
between the primers of the selected
solutions.

Zoom in Zoom in the view
Zoom out Zoom out the view
Center view Move the view to the center of the

sequence.
Increase base size Increase the size of a base.
Decrease base size Decrease the size of a base.
Switch on the view of
both the tags and the
masks.
Sequence annota-
tion/Show tags

Switch on and o� the display of the
tags.

Sequence annota-
tion/Show masks

Switch on and o� the display of the
masks.

Sequence annota-
tion/Hide annota-
tions

Switch o� the display of both the
tags and the masks.

Export view as... Export the current view as an im-
age �le.
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6.3 Properties and Heteroduplexes of a solution

[plugin menu]View > Properties & View > Heteroduplexes

During the prediction, properties and structures for the primers, the amplicons or pairs of primers and
the probes are computed. To view the properties or the heteroduplexes of a primer or an amplicon or a
probe, you may right click either in table or in the graphical visualization, or select the Propertiesitem
of the View menu. You can navigate through the selected solutions with the navigation buttons. You
can also print the properties of the current solution with th e Print button. Properties and structures are
also available via the reports.

Navigation buttons

The properties of a solution. Use the navigation buttons to i terate through the selected
solutions.

Navigation buttons

The heteroduplexes of a solution. Use the navigation button s to iterate through the
selected solutions.
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6.4 Description of the parameters

Oligo concentration : concentration of oligonucleotide in the solution, in nM (10� 9M).
[General/Reaction conditions]

Salt concentration (Na+ ) : concentration of monovalent salt in the solution, in mM (10� 3M).
[General/Reaction conditions]

Salt concentration (Mg2+ ) : concentration of divalent salt in the solution, in mM (10 � 3M).
[General/Reaction conditions]

Min length : minimal length, in bp, for the primers, the amplicons, or the probes.
[General/Primer ; General/Amplicon ; General/Molecular Beacon probe]

Max length : maximal length, in bp, for the primers, the amplicons, or the probes.
[General/Primer ; General/Amplicon ; General/Molecular Beacon probe]

Min T m : minimal melting temperature, in � C, for the primers, the amplicons, or the probes.
[General/Primer ; General/Amplicon ; General/Molecular Beacon probe]

Max Tm : maximal melting temperature, in � C, for the primers, the amplicons, or the probes.
[General/Primer ; General/Amplicon ; General/Molecular Beacon probe]

Min GC : minimal content in G/C bases, in percentage, for the primers or the probes.
[General/Primer ; General/Molecular Beacon probe]

Max GC : maximal content in G/C bases, in percentage, for the primers or the probes.
[General/Primer ; General/Molecular Beacon probe]

Min num of GC on 3' end : minimal occurrence of G/C bases in the 5 last bases for the primers.
[General/Primer]

Max num of GC on 3' end : maximal occurrence of G/C bases in the 5 last bases end for the
primers.
[General/Primer]

Max num of repeated G or C: maximal occurrence of repeated G or C for the primers or the probes.
[General/Primer ; General/Molecular Beacon probe]

Max num of repeated A or T : maximal occurrence of repeated A or T for the primers or the probes.
[General/Primer ; General/Molecular Beacon probe]

Max num repeated dinucleotides: maximal occurrence of repeated dinucleotides for the primers or
the probes.
[General/Primer ; General/Molecular Beacon probe]

G or C at 3' end : if checked, the last residue for the primers must be a G or a C.
[General/Primer]

Max ambiguous bases: Maximal occurrence of ambiguous bases for the amplicon, excepted the
primers.
[General/Amplicon]

Max Tm di�erence between the primers : Maximal di�erence between the Tm for the primers
de�ning the amplicon, in � C.
[General/Amplicon]

Min T a : Minimal annealing temperature, in � C.
[General/Amplicon]

Max Ta : Maximal annealing temperature, in � C.
[General/Amplicon]
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Min di� between T m and Ta di� : Minimal di�erence between the T m of the probe, i.e. the
annealing temperature of the probe on the reference sequence and the PCR temperature of annealing
Ta, in � C.
[General/Molecular Beacons probe]

Max di� between Tm and Ta di� : Maximal di�erence between the Tm of the probe, i.e. the
annealing temperature of the probe on the reference sequence and the PCR temperature of annealing
Ta, in � C.
[General/Molecular Beacons probe]

Min Molecular Beacon Tm Ta di� : Minimal di�erence between the T m of the Molecular Beacon
probe, i.e. the temperature of melting the hairpin, and the PCR temperature of annealing Ta, in
� C.
[General/Molecular Beacons]

Max Molecular Beacon Tm Ta di� : Maximal di�erence between the Tm of the Molecular Beacon
probe, i.e. the temperature of melting the hairpin, and the PCR temperature of annealing Ta, in
� C.
[General/Molecular Beacons]

Selected tails : List of tails used to generate the Molecular Beacon. Those tails are selected from
the available tails.
[General/Molecular Beacons Tails]

� G method : list of available theoretical methods to evaluate the �G.
[Advanced/Method]

Tm method for primers/amplicons/Molecular Beacons probes: list of available theoretical methods
to evaluate the Tm for the primers, amplicons, and probes.
[Advanced/Method]

Max consecutive matches: Maximal number of consecutive matches, in bp, between a primer and
the DNA sequence before considering a binding.
[Advanced/Primer unicity]

Max 3' consecutive matches: Maximal number of consecutive matches, in bp, between the 3' end
of a primer and the DNA sequence before considering a binding.
[Advanced/Primer unicity]

Max percent of matches: Maximal percentage of matches between a primer and the DNA sequence
before considering a binding.
[Advanced/Primer unicity]

Check using the Amplify method: Check the binding of a primer with the DNA sequence with the
Amplify method.
[Advanced/Primer unicity]

Min � G (probe) Hairpin : Discard primers or probes forming a hairpin with an energy below the
given �G in kCal/mol.
[Advanced/Primer secondary structure ; Advanced/Molecular Beacon probe secondary structure]

Min � G 3' Hairpin : Discard primers forming a 3' hairpin with an energy below the given �G in
kCal/mol.
[Advanced/Primer secondary structure]

Min � G (probe) homoduplex : Discard primers or probes forming a homoduplex with an energy
below the given �G in kCal/mol.
[Advanced/Primer secondary structure ; Advanced/Molecular Beacon probe secondary structure]

Min � G 3' homoduplex : Discard primers forming a homoduplex with an energy below the given
�G in kCal/mol.
[Advanced/Primer secondary structure]
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Max number of hydrogen bonds: Discard primers forming homoduplex or heteroduplex having a
number of hydrogen bonds above the given limit.
[Advanced/Primer secondary structure ; Advanced/Pair of primers secondary structure]

Min � G heteroduplex: Discard primers forming heteroduplex with an energy belowthe given �G
in kCal/mol.
[Advanced/Pair of primers secondary structure]

Min � G heteroduplex in 3' : Discard primers forming a heteroduplex in 3' with an energybelow
the given �G in kCal/mol.
[Advanced/Pair of primers secondary structure]

Min/Max � G Molecular Beacons Hairpin : Discard Molecular Beacon probes forming hairpin with
an energy outside the given �G range, in kCal/mol.
[Advanced/Molecular Beacons]

Min Molecular Beacon/Primer dimers � G : Discard Molecular Beacon probes forming a duplex
with the primers and having an energy below the given �G, in kC al/mol.
[Advanced/Molecular Beacons]
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Tools

7.1 Property calculator

With the property calculator, you can select properties to be calculated { for any sequences or solutions
of a prediction { and specify the associated parameters. It is important to note that the results of such
a computation will not be stored with the solutions of the prediction.

The property calculator. Select the properties and click on Compute.

The results of the computation for the selected solutions are presented as a hierarchy. It is possible
to expand or collapse solutions or parts of the results respectively with the plus ( ) or minus ( ) sign.
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The Property Calculator. Results of the computed propertie s for the selected solutions.

With the Save as ...button, the results can be exported as a text �le, as a CSV (Comma-separated
values) �le which can be read by most spreadsheet programs oras a Microsoft Excel �le. A summary
of the properties and their associated parameters is given if the export is done as a text �le. The Print
button opens the Report Manager. It is described at the page70.

The property Calculator remains free of charge independently of the type of licenses used.
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7.2 Sequence Search

This tool enables the search of a speci�c sequence in severaldatabases of the NCBI web site by entering
criteria. The available �elds for the search are the Accession number, Author name, EC/RN number,
Feature key, Filter, Gene name, Issue, Journal name, Keyword, ... The search can also be carried out on all
the �elds. Di�erent criteria can be combined together with t he AND, OR or NOT logical operators. Once
the search is completed, one can select a sequence and download it in the Sequence tab. It is important
to note that the previous sequence in the Sequence tab is replaced.

The Sequence Search tool. Enter a keyword and a database for t he search. It is possible
to re�ne the search by entering more criteria through the More criteria button.

Once the search is completed, you can navigate throughout th e results, select and
download a sequence, or go back and re�ne your search.
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7.3 Report manager

The report manager is a tool that provides the user with formating facilities to present results such as the
solutions of a prediction (PCR, TaqMan, TaqMan MGB, or Molecular Beacon probes) or the properties
of sequences. This tool has two menus : theFile and Con�guration menus. The �rst menu permits to
export to a PDF �le or to directly print the report. The second menu deals with the con�guration, i.e.
the formating of the di�erent elements of the report, the page and the user information.

Command in the
File menu.

Description

Export as PDF Export the report as a PDF docu-
ment.

Print ... Print the report.
Close Close the report manager. You will

be prompted to save the con�gura-
tion, if needed.

Command in
the Con�guration
menu.

Description

Load Load the con�guration from a �le.
Save Save the current con�guration in a

�le.
Save as ... Save the current con�guration in a

new �le.
Edit Modify the con�guration for the re-

port.

It is possible to add an image or logo to the report, either viathe contextual menu (right click with
the mouse) or via the Edit item of the Con�guration menu. Comments, consisting of a simple text, can
also be added to the �rst page of the report. The comments are not saved for subsequent uses of the
report manager.

The Report Manager for the PCR predicition. The contextual m enu, obtained by a right
click, is shown.

7.3.1 The di�erent tabs of the con�guration dialog box

The available tabs depends on the context of the report. However, some like the Fonts or the User
information tabs are always shown.
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The Fonts tab

The Fonts tab consists of a list of styles on the left and the de�nition of the selected style on the
right. The available parameters for the styles are the following.

Font
Select a font in the list of available fonts for your system.

Style
Select the format for the style : Normal, Bold, Italic, or Bol d Italic.

Size
Select the size of the font to be applied.

Color
Select from the list the color for the style.

Background
Select the color of the background for the style.

Underline
Check the box if you want to underline the text. It is also possible to select a color.

Enumeration
One can select a style of enumeration from the list or de�ne the string of characters to add in
front by selecting the Other ... item of the list. The characters to add after the enumeration
can also be customized.

The Report Manager con�guration dialog box for the PCR predi ction.
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The User informationtab

One can enter personnal details and other data about the report in this tab.

User data
Enter your �rst and last name as well as your email.

Company information
Enter the information about your company. You can specify a logo that will appear on the
�rst page of the report.

Report information
Enter the data about the current report such as the title, the subtitle, the project identi�er or
a reference.

The User Information tab for the Report Manager con�guratio n dialog box.

The Sequencetab

The Sequencetab let you specify the style and layout format for sequencesin the report.

Sequence font
This group of options is similar to the one of theFonts tab.

Sequence format
This group of options changes the layout of sequences. Several format are available:

Text . The sequence is displayed as a simple list of symbols.
FASTA . The sequence is displayed in the FASTA format. E.g.
> Title
ACGTACGTACGTACGTACGTACGTACGTACGTACGTACGTACGTACGT
ACGTACGTACGTACGTACGTACGTACGTACGT
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GenBank . The sequence is displayed in the GenBank format if such information is
available. Otherwise, the FASTA format is used instead.
EMBL . The sequence is displayed in the EMBL format if such information is available.
Otherwise, the FASTA format is used instead.
Other . The sequence is split in lines having by default 50 symbols separated by a space
every 10 symbols. E.g.:
1 catgcaagtc gaacggagtt atattgtagc ttgctacgat ataacttagt
51 ggcagacggg tgagtaatgt ataggaatct acctagtagt acggaataa t
101 tgttggaaac ggcaactaat accgtatacg ccctacgggg gaaaaatt ta
151 ttgctattag atgagcctat attagattag cttgttggtg gggtaata gc

Primers, probes, ...
With this group of options one can change the appearance of primers, ... Check theFonts
tab for a description of the available options.

The Table property tab
The layout format of tables are set in this tab. A table is divi ded in three parts : the columns
header, the row headers and the content of the table. For eachpart, one can select a font and
all the attributes. They are described in the Fonts tab. In addition, the layout and format of
the borders can be selected.

Column headers
Row Content of

headers the table

Borders
Select the type of borders, the width of the lines and their colors.

The Pagetab
The format of the page (A4, A5, US letter, ...) as well as its orientation can be speci�ed in
this tab.

Page format
Select from the list the format for the pages.

Page orientation
Select the orientation for the pages : Portrait or Landscape.
Margins
Specify the top, bottom, left/interior, right/exterior ma rgins.
Layout
Select the layout of the pages :

Normal : Apply the same layout to the even and odd numbered pages of the report.
Book : The report will be print as a book or recto-verso. The recto is the right-hand
page (odd numbered) and the verso the left-hand page (even numbered page). The
left and right margins becomes the interior and exterior margins.

The Report contenttab
This tab permits to reduce the content of the report to some elements. Its content depends
on the type of report.

Show sequence
Include the sequence of the prediction.
Show parameters
Include the parameters used in the prediction.
Show statistics
Include the statistics of the prediction.
Show results
Include the selected solutions in the report. The best secondary structures for the solutions
can be included in the report based on criteria such as the length of the helix, the energy
of the structure.
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Chapter 8

BioXpress End User License
Agreement

IMPORTANT - PLEASE READ CAREFULLY

BioXpr S.A. ("BioXpr"), the owner of the BioXpress Software (the "Software"), is willing to grant you, or, in
the case that you represent a corporation or other organizat ion, that corporation or organization (collectively and
interchangeably, "Licensee" or "You") a limited, personal , non-exclusive license to use the "Software" set forth
on the one or more order forms, paper or electronic, You have entered into with BioXpr relating to the Software
(each, an "Order Form") subject to Your acceptance and agree ment to be bound by the terms of this End User
Software License Agreement (together with the terms and conditions of the Order Form, the "Agreement").

BY CLICKING ON THE "I ACCEPT" BUTTON BELOW (OR BY OTHERWISE IN STALLING OR USING
ANY SOFTWARE), YOU ACKNOWLEDGE THAT YOU HAVE READ, UNDERSTA ND, AND AGREE TO
BE BOUND BY THE TERMS OF THIS AGREEMENT AS IT RELATES TO THAT SO FTWARE AS OF THE
DATE ON WHICH YOU FIRST CLICK THE "ACCEPT" BUTTON, OR OTHERWI SE FIRST INSTALL
OR USE THE SOFTWARE (SUCH DATE, THE "EFFECTIVE DATE"). IF YOU DO NOT AGREE TO
THE TERMS OF THIS AGREEMENT, BIOXPR IS UNWILLING TO GRANT YOU A LICENSE TO THE
SOFTWARE, YOU SHOULD CLICK ON THE "I DO NOT ACCEPT" BUTTON BEL OW TO DISCONTINUE
THE INSTALLATION PROCESS, AND YOU SHOULD PROMPTLY RETURN TH E SOFTWARE TO THE
PLACE FROM WHICH YOU OBTAINED IT FOR A REFUND.

1. De�nitions
1.1 The following terms and expressions shall have the following meanings:
Additional Terms: the terms and conditions and policies app licable to Your use of the BioXpress Software

and the BioXpr Services, in addition to this Agreement.
A�liate: any corporation, company or other entity that dire ctly or indirectly controls, is controlled by, or

is under common control with, BioXpr. For the purpose of this de�nition, the word "control" shall mean the
direct or indirect ownership of more than �fty percent (50%) of the outstanding voting stock of the corporation,
company, or other entity.

Agreement: this End User License Agreement, as may be renewed and/or amended from time to time.
Documentation: any online or otherwise enclosed documentation provided by BioXpr.
E�ective Date: the date on which this Agreement is entered in to by clicking on the ACCEPT button as stated

above or upon installation or use of the BioXpress Software by You, whichever occurs earlier.
Emergency Service(s): means services that connect a user toemergency services personnel or public safety

answering points pursuant to applicable local and or nation al regulatory requirements.
IP Rights: means (i) patents, pending patent applications, designs, trade marks and trade names (whether

registered or unregistered), copyright and related rights , database rights, knowhow and con�dential information;
(ii) all other intellectual property rights and similar or e quivalent rights anywhere in the world which currently
exist or are recognised in the future; and (iii) application s, extensions and renewals in relation to any such rights.

Password: refers to a code You select, which, in combination with the User ID, gives You access to Your User
Account.

BioXpr: refers to the company established under the laws of B elgium, BioXpr S.A, with its address at Rue
du SÂ�minaire, 22 - B-5000 Namur, VAT no. BE 0861 263 988.

BioXpress API: application program interface consisting o f the set of routines utilized by the BioXpress
Software to provide the BioXpress Software functionality f or a given platform or operating system, BioXpress API
being included in or linked to the BioXpress Software as well as any future versions, improvements, developments,
programming �xes, updates and upgrades thereof.
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BioXpr Promotional Materials: any and all trademarks, name s, signs, logos, banners, and any other materials,
in whatever form, owned and/or used by BioXpr for the promoti on of its company, its products and activities.

BioXpr Services: the BioXpr Website and any other products a nd services made available to You by BioXpr
or its A�liates, in addition to the BioXpress Software.

BioXpress Software or the Software: the software distribut ed by BioXpr for oligonucleotides prediction, includ-
ing without limitation the BioXpress API, UI and Documentat ion, as well as any future versions, improvements,
developments, programming �xes, updates and upgrades thereof.

BioXpr Sta�: the o�cers, directors, employees and agents of BioXpr or its A�liates, or any other persons
hired by BioXpr or its A�liates.

BioXpr Website: any and all elements, contents and the 'look and feel' of the website available under the
URL, www.BioXpr.com , - among other URL's -, from which websi te the BioXpress Software can be downloaded.

Terms: has the meaning given in the "Additional Terms" preli minary term above.
UI: the user interface of the BioXpress Software.
User Account: refers to the account with User ID and Password that You create for Your use of the BioXpress

Software, or any other software or web services o�ered by BioXpr.
User ID: refers to an identi�cation code You selected, which in combination with the Password, gives access

to Your User Account.
You: You, the end user of the BioXpress Software, also used in the form "Your" where applicable.
1.2 References to the singular include the plural and vice versa, and references to one gender include the other

gender.
1.3 Any phrase introduced by the expressions "including", " include", "in particular" or any similar expression

shall be construed as illustrative and shall not limit the se nse of the words preceding those terms.
2. License and Restrictions 2.1 License: Subject to the terms of this Agreement, BioXpr hereby grants You

a limited, personal, non-commercial, non-exclusive, non-sublicensable, non-assignable, free of charge license to
download, install and use the BioXpress Software on Your computer, for the sole purpose of predicting oligonu-
cleotide for research use. You are allowed to use the BioXpress Software at work in accordance with this Agreement
and any applicable Additional.

2.2. Installation: You may install, use, access, display and run the Software on any number of computers,
such as workstations, web servers or other devices ("Workstations"). You may also store or install the Software
on storage devices, such as a network server, used to installor run the Software on Your other Workstations over
an internal network. However, a license for the Software may not be shared among multiple users, as each license
is limited to a single authorized user. If You wish to expand t he number of authorized users of the Software,
You may purchase additional licenses from BioXpr. Any addit ional licenses will be subject to the terms of this
Agreement.

2.3. Fees and Payment 2.3.1 License Fee: In consideration ofthe rights to the Software provided under this
Agreement, You will pay BioXpr the fees ("Fees") listed on th e BioXpr Web site applicable to the Software.

2.3.2 Payment: Payment of the Fees must be made in euros (EUR), and must be paid via credit card or direct
withdrawal from a bank account. You grant BioXpr the right to charge the credit card or bank account speci�ed
in the applicable Order Form for all Fees incurred under this Agreement. On the E�ective Date, You will remit
to BioXpr a one-time payment of the Fees as set forth on the Ord er Form based on the number of end-user
licenses You are purchasing. You may, at any time during the t erm of the Agreement, increase the number of
licenses which you have purchased upon providing written notice to BioXpr, together with payment of BioXpr's
then-current Fees associated with such number of additional end-user licenses. All Fees are non-refundable. Your
obligation to pay Fees not subject to a reasonable dispute will be unconditional and not subject to abatement,
seto� or defense of any kind. Fees exclude all applicable sales, use, and other taxes, fees, duties and similar
charges, and You will be responsible for payment of all such taxes (other than taxes based on BioXpr's income),
fees, duties, and charges. Any portion of the Fees not paid when due will accrue interest at 18% per annum (1.5%
per month) or the maximum rate permitted by applicable law, w hichever is less, from the due date until paid.

2.4 No Granting of Rights to Third Parties: You will not sell, assign, rent, lease, distribute, export, import, act
as an intermediary or provider, or otherwise grant rights to third parties with regard to the BioXpress Software
or any part thereof.

2.5 No Modi�cations: You will not undertake, cause, permit o r authorize the modi�cation, creation of deriva-
tive works, translation, reverse engineering, decompiling, disassembling or hacking of the BioXpress Software or
any part thereof except to the extent permitted by law.

2.6 Third Parties: The BioXpress Software may be incorporat ed into, and may incorporate itself, software
and other technology owned and controlled by third parties. Any such third party software or technology that is
incorporated in the BioXpress Software falls under the scope of this Agreement. Any and all other third party
software or technology that may be distributed together wit h the BioXpress Software will be subject to You
explicitly accepting a license agreement with that third pa rty. You acknowledge and agree that You will not enter
into a contractual relationship with BioXpress or its A�lia tes regarding such third party software or technology
and you will look solely to the applicable third party and not to BioXpr or its A�liates to enforce any of your
rights.
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2.7 Exclusive Ownership: Any and all IP Rights in the BioXpre ss Software, the BioXpr Website and the BioXpr
Promotional Materials are and shall remain the exclusive pr operty of BioXpr and/or its licensors. Nothing in this
Agreement intends to transfer any such IP Rights to, or to ves t any such IP Rights in, You. You are only entitled
to the limited use of the IP Rights granted to You in this Agree ment. You will not take any action to jeopardize,
limit or interfere with BioXpr's IP Rights. Any unauthorize d use of BioXpr's IP Rights is a violation of this
Agreement as well as a violation of intellectual property la ws and treaties, including without limitation copyright
laws and trademark laws. All title and IP Rights in and to any t hird party content that is not contained in the
BioXpress Software, but may be accessed through use of the BioXpress Software, is the property of the respective
content owners and may be protected by applicable copyright or other intellectual property laws and treaties.

2.8 No Removal of Notices: You agree that You will not remove, obscure, make illegible or alter any notices
or indications of the IP Rights and/or BioXpr's rights and ow nership thereof, whether such notice or indications
are a�xed on, contained in or otherwise connected to any mate rials.

2.9 Use of BioXpress software 2.9.1 You may make use of the BioXpress API provided that: (i) Your use of
the BioXpress API is for legitimate purposes only and shall n ot adversely a�ect the functionality or performance
of the BioXpress Software or services provided by BioXpr; an d

(ii) You will monitor the BioXpr Website in order to ensure th at You are aware of any changes in the BioXpress
API Terms of Use. If such changes are not acceptable to You, You will immediately stop using the BioXpress
API and, where applicable, the BioXpress Software.

2.9.2 If You are interested in using the BioXpress API for a pu rpose which is not permitted under this
Agreement or the BioXpress API Terms of Use, You will have to o btain BioXpr's prior written consent and
explicitly agree upon any further commercial terms.

2.10 BioXpr Promotional Materials: Nothing in this Agreeme nt will give You any right to use the BioXpr
Promotional Materials.

3. What You should and should not expect from BioXpress
3.1 No Warranties: Installing BioXpress Software enables You to predict oligonucleotides sequence for re-

search use. BIOXPR DOES NOT WARRANT THAT: (A) THE OPERATION O F THE SOFTWARE OR
HARDWARE WILL BE UNINTERRUPTED OR ERROR-FREE OR THAT FUNCTI ONS CONTAINED IN
THE SOFTWARE WILL OPERATE IN COMBINATIONS OF SOFTWARE OR HAR DWARE THAT MAY
BE SELECTED FOR USE BY YOU; (B) THE SOFTWARE WILL MEET YOUR REQ UIREMENTS OR EX-
PECTATIONS; OR (C) ANY RESULTS, OUTPUT, OR DATA PROVIDED THR OUGH OR GENERATED BY
THE SOFTWARE WILL BE ACCURATE, UP-TO-DATE, COMPLETE OR RELI ABLE. EXCEPT AS EX-
PRESSLY STATED IN THIS SECTION 3.1, TO THE MAXIMUM EXTENT PER MITTED BY LAW, BIOXPR
SPECIFICALLY DISCLAIMS ALL OTHER WARRANTIES, EXPRESS OR IM PLIED, ORAL OR WRITTEN,
ARISING BY LAW OR OTHERWISE, RELATING TO THIS AGREEMENTAND T HE SOFTWARE AND ANY
SERVICES PROVIDED TO YOU, INCLUDING WITHOUT LIMITATION, AN Y IMPLIED WARRANTIES
OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITL E AND NON-INFRINGEMENT
OF THIRD PARTY RIGHTS.

3.2 Utilization of Your Computer: BioXpress Software may ut ilize the processor and bandwidth of the com-
puter (or other applicable device) You are utilizing, for th e limited purpose of predicting oligonucleotide sequences
or related functionalities. BioXpr will use its commercial ly reasonable e�orts to protect the privacy and integrity
of the computer resources (or other applicable device) You are utilizing and of Your oligonuclotides prediction,
however BioXpr cannot give any warranties in this respect.

3.3 New Versions of the BioXpress Software: BioXpr, in its sole discretion, reserves the right to add additional
features or functions, or to provide programming �xes, upda tes and upgrades, to the BioXpress Software. BioXpr
has no obligation to make available to You any subsequent versions of the BioXpress Software. You may have to
enter into a renewed version of this Agreement, in the event you want to download, install or use a new version
of the BioXpress Software.

3.4 Suspension: BioXpr may, in its sole discretion and to the maximum extent permitted within Your ju-
risdiction, modify or discontinue or suspend Your ability t o use any version of the BioXpress Software, and/or
disable any BioXpress Software You may already have accessed or installed without any notice to You, for the re-
pair, improvement, and/or upgrade of the underlying techno logy or for any other justi�able reason, including but
not limited to, circumstances where You, at BioXpr's discre tion, are in breach of the Terms, creating problems,
possible legal liabilities, or engaging in fraudulent, imm oral or illegal activities, or for other similar reasons.

3.5 Version Restrictions: You acknowledge that the Softwar e identi�ed as a "beta" version("Beta Software") is
provided solely as a convenience for You. Beta Software may include additional features or functionality currently
under development for inclusion in the Software, but is not c urrently supported by BioXpr.

4. What we expect from You
4.1 Lawful purposes: You will use the BioXpress Software solely for lawful purposes. In this respect You

may not, without limitation use any type of spider, virus, wo rm, trojan-horse, time bomb or any other codes or
instructions that are designed to distort, delete, damage o r disassemble the BioXpress Software.

4.2 Representations: You represent and warrant that You are authorized to enter into and comply with the
Terms. Furthermore, You represent and warrant that You will at any and all times meet with Your obligations
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under the Terms, as well as any and all laws, regulations and policies that may apply to the use of the BioXpress
Software and/or the BioXpr Services.

4.3 Indemni�cation: YOU AGREE TO INDEMNIFY, DEFEND AND HOLD BIOXPR AND ITS AFFIL-
IATES HARMLESS FROM AND AGAINST ANY AND ALL LIABILITY AND COS TS, INCLUDING REA-
SONABLE ATTORNEYS' FEES INCURRED BY SUCH PARTIES, IN CONNEC TION WITH OR ARISING
OUT OF YOUR (A) VIOLATION OR BREACH OF ANY TERM OF THIS AGREEME NT OR ANY APPLI-
CABLE LAW OR REGULATION, WHETHER OR NOT REFERENCED HEREIN, O R (B) VIOLATION OF
ANY RIGHTS OF ANY THIRD PARTY, OR (C) USE OR MISUSE OF THE BIOXP RESS SOFTWARE.

4.4 Utilization of Your Computer: If Your use of the BioXpres s Software is dependant upon the use of a
processor and bandwidth owned or controlled by a third party , You acknowledge and agree that Your license to
use the BioXpress Software is subject to You obtaining consent from the relevant third party for such use. You
represent and warrant that by accepting this Agreement and u sing the BioXpress Software, You have obtained
such consent.

4.5 Con�dentiality: You acknowledge that the Software cont ains con�dential and proprietary information of
BioXpr, including without limitation the Source Code, inve ntions, algorithms, know how and other proprietary
information contained therein (collectively, "Con�denti al Information"). You agree to protect the Con�dential
Information with at least the same degree of care employed with respect to Your own con�dential or proprietary
information. You will not use the Con�dential Information f or any purpose other than in connection with Your
use of the Software under the Agreement. Except as otherwiseset forth in this Agreement, under no circumstances
will You allow any third party to have access to the Software.

4.6 Export Restrictions: BioXpress Software may be subject to international rules that govern the export
of software. You shall comply with all applicable internati onal and national laws that apply to the BioXpress
Software as well as end-user, end-use and destination restrictions issued by national governments.

5. Term, Termination, Updates 5.1 Term: This Agreement will be e�ective as of the E�ective Date and will
remain e�ective until terminated by either BioXpr or You as s et out below. The Additional Terms will be e�ective
as of the date upon which they are accepted by You or You use the relevant BioXpr Service (as applicable), and
will remain e�ective until terminated by either BioXpr or Yo u as set out below and/or in the applicable terms.

5.2 Termination: You may terminate the Terms with immediate e�ect at any time. Without limiting other
remedies, BioXpr may limit, suspend, or terminate this lice nse and Your use of BioXpress Software and BioXpr
Services, prohibit access to the BioXpr Website and delete Your User Account and/or User ID, with immediate
e�ect, automatically and without recourse to the courts, if we think that You are in breach of the Terms, creating
problems, legal liabilities (actual or potential), infrin ging someone else's intellectual property rights, engaging in
fraudulent, immoral or illegal activities, or for other sim ilar reasons. BioXpr shall e�ect such termination by
providing notice to You to the email address You have provide d, and/or by preventing Your access to Your User
Account. We reserve the right to cancel User Accounts that ha ve been inactive for more than two (2) years.

5.3 Consequences of Termination: Upon termination of this A greement and the Additional Terms: (a) all
licenses and rights to use the BioXpress Software and the BioXpr Services shall immediately terminate; (b)
You will immediately cease any and all use of the BioXpress Software and BioXpr Services; and (c) You will
immediately remove the BioXpress Software from all hard dri ves, networks and other storage media and destroy
all copies of the BioXpress Software in Your possession or under Your control.

5.4 New Versions: BioXpr reserves the right to change this Agreement at any time by publishing the revised
Agreement on the BioXpr Website. The revised Agreement shal l become e�ective within thirty (30) days of such
publication, unless You expressly accept the revised Agreement earlier by clicking on the accept button. Your
express acceptance or Your continued use of the BioXpress Software after expiry of the notice period of thirty
(30) days, shall constitute Your acceptance to be bound by th e terms and conditions of the revised Agreement.
BioXpr reserves the right to change any of the Additional Ter ms from time to time and such changes shall become
e�ective either within thirty (30) days of publication of th e revised version on the BioXpr Website (unless You
expressly accept the revised terms earlier by clicking on the accept button if this option is made available), or
within the timeframe set out in the applicable terms if di�er ent.

6. Disclaimer of Warranties and Limitation of Liability
6.1 No Warranties: THE BIOXPRESS SOFTWARE IS PROVIDED "AS IS " WITH NO WARRANTIES

WHATSOEVER; BIOXPR DOES NOT, EITHER EXPRESSED, IMPLIED OR S TATUTORY, MAKE ANY
WARRANTIES, CLAIMS OR REPRESENTATIONS WITH RESPECT TO THE B IOXPRESS SOFTWARE,
INCLUDING, WITHOUT LIMITATION, WARRANTIES OR CONDITIONS O F QUALITY, PERFOR-
MANCE, NON-INFRINGEMENT, MERCHANTABILITY, OR FITNESS FOR USE FOR A PARTICULAR
PURPOSE. BIOXPR FURTHER DOES NOT REPRESENT OR WARRANT THAT T HE BIOXPRESS SOFT-
WARE WILL ALWAYS BE AVAILABLE, ACCESSIBLE, UNINTERRUPTED, TIMELY, SECURE, ACCU-
RATE, COMPLETE AND ERROR-FREE.

6.2 Your own Risk: You acknowledge and agree that the entire r isk arising out of Your use of the BioXpress
Software remains with You, to the maximum extent permitted b y law.

6.3 Limitation of Liability: THE LIABILITY OF BIOXPR UNDER T HIS AGREEMENT, REGARDLESS
OF THE BASIS OF LIABILITY OR THE FORM OF ACTION, WILL NOT EXCEE D THE FEES PAID TO
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BIOXPR FOR THE PORTION OF THE SOFTWARE OR SERVICES CAUSING TH E LIABILITY. IN NO
EVENT WILL BIOXPR BE LIABLE FOR ANY INDIRECT, SPECIAL, INCID ENTAL OR CONSEQUEN-
TIAL DAMAGES, HOWEVER CAUSED, WHETHER FOR BREACH OF CONTRAC T, NEGLIGENCE OR
OTHERWISE, AND REGARDLESS OF WHETHER BIOXPR HAS BEEN ADVISE D OF THE POSSIBILITY
OF THOSE DAMAGES, INCLUDING WITHOUT LIMITATION, THE USE OR I NABILITY TO USE THE
SOFTWARE, OR ANY RESULTS OBTAINED FROM OR THROUGH THE SOFTWA RE. BIOXPR WILL
NOT BE LIABLE FOR ANY NETWORK-RELATED PROBLEMS ATTRIBUTABL E TO THE SOFTWARE
OR CHANGES TO NETWORK CONFIGURATION THAT MAY AFFECT THE PERF ORMANCE OF THE
SOFTWARE.

IN NO EVENT SHALL BIOXPR, ITS AFFILIATES, ITS LICENSORS OR TH E BIOXPRESS STAFF BE
LIABLE, WHETHER IN CONTRACT, WARRANTY, TORT (INCLUDING NEG LIGENCE), PRODUCT LIA-
BILITY OR ANY OTHER FORM OF LIABILITY, FOR: 6.3.1 ANY INDIREC T, INCIDENTAL, SPECIAL OR
CONSEQUENTIAL DAMAGES (INCLUDING WITHOUT LIMITATION ANY L OSS OF OR CORRUPTION
TO DATA, INTERRUPTION, COMPUTER FAILURE OR PECUNIARY LOSS) ARISING OUT OF THE USE
OR INABILITY TO USE THE BIOXPRESS SOFTWARE; AND

6.3.2 ANY LOSS OF INCOME, BUSINESS OR PROFITS (WHETHER DIREC T OR INDIRECT) ARISING
OUT OF THE USE OR INABILITY TO USE THE BIOXPRESS SOFTWARE;

6.3.3 ANY LOSS OR DAMAGE WHICH MAY BE INCURRED BY YOU AS A RESUL T OF; (I) IMPROPER
USE OF THE INFORMATION GENERATED BY THE BIOXPRESS SOFTWARE;

(II) THE SUSPENSION OR TERMINATION OF THIS AGREEMENT BY YOU O R BY BIOXPR FOR
ANY REASON; AND

(III) THE RELEASE OR THE DECISION NOT TO RELEASE NEW VERSIONS OF THE BIOXPRESS
SOFTWARE TO YOU.

6.4 THE LIMITATIONS ON BIOXPR'S LIABILITY TO YOU IN PARAGRAP H 6.3 ABOVE SHALL AP-
PLY WHETHER OR NOT BIOXPR, ITS AFFILIATES OR THE BIOXPR STAFF HAVE BEEN ADVISED
OF THE POSSIBILITY OF SUCH LOSSES OR DAMAGES ARISING.

6.5 NOTHING IN THIS AGREEMENT IS INTENDED TO EXCLUDE OR RESTR ICT OR SHALL BE
CONSTRUED AS EXCLUDING OR RESTRICTING THE LIABILITY OF BIOX PR FOR (I) THE DEATH
OR PERSONAL INJURY CAUSED BY THE NEGLIGENCE OF BIOXPR, THE BI OXPR STAFF OR ITS
AGENTS, OR (II) ANY LIABILITY WHICH CANNOT BE LIMITED OR EXCL UDED BY LAW.

6.6 Jurisdiction's Limitations: As some jurisdictions do n ot allow some of the exclusions or limitations as set
forth above, some of these exclusions or limitations may not apply to You. In such event the liability will be
limited to the maximum extent possible within the applicabl e legislation.

7. Additional Terms
7.1 If You are interested in doing anything which is not permi tted under this Agreement or by one of the

above Additional Terms, You will have to obtain BioXpr's pri or written consent and explicitly agree upon any
further terms.

7.2 Your Con�dential Information and Your Privacy: BioXpr i s committed to respecting Your privacy and
the con�dentiality of Your personal data. Your personal dat a will be solely used for the purpose of creating your
user account and managing your license information. BioXpr will not allow that your personal information will
be distributed to third-parties without your prior consent . If You object to Your information being used in the
way set out in the Privacy Policy then please do not use the Bio Xpr Services.

8. Miscellaneous 8.1 Entire Agreement: The terms and condit ions of the Terms constitute the entire agreement
between You and BioXpr with respect to the subject matter her eof and will supersede and replace all prior
understandings and agreements, in whatever form, regarding the subject matter. Nothing in this clause shall
exclude or restrict the liability of either You or BioXpr ari sing out of fraud or fraudulent misrepresentation.

8.2 Partial Invalidity: If any provision of the Terms, or any part of a provision, is found by any court or
administrative body of competent jurisdiction to be illega l, invalid or unenforceable, and the provision (or part-
provision) in question is not of a fundamental nature to the T erms as a whole, the legality, validity or enforceability
of the remainder of the Terms (including the remainder of the term which contains the relevant provision) shall
not be a�ected.

8.3 No waiver: The failure to exercise, or delay in exercising, a right, power or remedy provided by the Terms
or by law shall not constitute a waiver of that right, power or remedy. If BioXpr waives a breach of any provision
of the Terms this shall not operate as a waiver of a subsequentbreach of that provision, or as a waiver of a breach
of any other provision.

8.4 Assignment: You are not allowed to assign the Terms or any rights hereunder. BioXpr is allowed at its
sole discretion to assign the Terms or any rights hereunder to any third party, without giving prior notice.

8.5 Applicable Law and Competent Court: The Terms shall be go verned by and interpreted in accordance
with the laws of Belgium and shall be subject to the jurisdict ion of the courts of Namur, Belgium.

8.6 Language: The original English version of the Terms may have been translated into other languages. In
the event of inconsistency or discrepancy between the English version and any other language version, the English
language version shall prevail.
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8.7 Survival: The terms of paragraphs 2.7, 5 and 6 of this Agreement, and any other provision of the Additional
Terms which is expressed to survive or operate in the event of termination, shall survive termination of this
Agreement and the applicable Additional Terms for whatever reason.

YOU EXPRESSLY ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT AND UNDER-
STAND THE RIGHTS, OBLIGATIONS, TERMS AND CONDITIONS SET FOR TH HEREIN. BY CLICKING
ON THE ACCEPT BUTTON AND/OR CONTINUING TO INSTALL THE BIOXPR ESS SOFTWARE, YOU
EXPRESSLY CONSENT TO BE BOUND BY ITS TERMS AND CONDITIONS AND GRANT TO BIOXPR
THE RIGHTS SET FORTH HEREIN.
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Copyright and Trademark
information

Copyright c
 2008, 2009 BioXpr. All Rights Reserved.

Microsoft, Windows, Windows XP, the Windows logo, Windows Vista, the Windows Vista Start
button logo are trademarks or registered trademarks of Microsoft Corporation in the United States
and/or other countries.

Java is a trademark of Sun Microsystems, Inc.

Mac OS X is a trademark of Apple Inc.

All other trademarks, trade names, or company names referenced herein are used for identi�cation
only and are the property of their respective owners.
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